summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-22 09:21:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-22 09:58:02 +0200
commitad671bd5c81db2b46654312c6d2e6a305d867e47 (patch)
tree6b3a2de6645bef570c48a137d72b5518cc478c14 /dev-python/pgspecial
parentdev-python/importlib_resources: Bump to 5.1.4 (diff)
downloadgentoo-ad671bd5c81db2b46654312c6d2e6a305d867e47.tar.gz
gentoo-ad671bd5c81db2b46654312c6d2e6a305d867e47.tar.bz2
gentoo-ad671bd5c81db2b46654312c6d2e6a305d867e47.zip
dev-python/pgspecial: Bump to 1.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest1
-rw-r--r--dev-python/pgspecial/pgspecial-1.13.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index 1ea7fa72cc16..83f1275385ec 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1 +1,2 @@
DIST pgspecial-1.12.1.tar.gz 47945 BLAKE2B e189695a3689f76f6fd3afc3b5f7c412dfc0a79fcd2465f8bca29b81de1609e045f0237fcc6b63a75c7df1d9a31d4c04cd8fa227493d6cce4cd6863a4c36cd2a SHA512 d1ef6462ab3d1cf5fe35f0dabc61698d7c2cf7e35b292c3cb540cce4bd613485d7dca53fd549a134209461c31c8144d72d1af1ee8aad5569766d9387b7e10e0b
+DIST pgspecial-1.13.0.tar.gz 49204 BLAKE2B 7269fc94fc0672db1880ba4b76c8926b6a3c995aac3fca77add7ae6756fcc3295d8d32fcede37cd3fa2d82c82aebfc26d91ed50b4294c5206f04d4c72742b45b SHA512 de2560106fbad14f2095ace468c8490cb325aedb772f649f20a0b5fe65f19afeed33f219d3a6eca683a63b418741a9906a01f7c4bdd8734868517faeba791026
diff --git a/dev-python/pgspecial/pgspecial-1.13.0.ebuild b/dev-python/pgspecial/pgspecial-1.13.0.ebuild
new file mode 100644
index 000000000000..f83f61db75dc
--- /dev/null
+++ b/dev-python/pgspecial/pgspecial-1.13.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of PostgreSQL meta commands"
+HOMEPAGE="https://github.com/dbcli/pgspecial"
+SRC_URI="https://github.com/dbcli/pgspecial/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+DOCS=( License.txt README.rst changelog.rst )