summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-22 19:00:39 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-23 20:49:03 +0200
commitc26b34c92ffa6e64783067266d1885ddd3ba22e9 (patch)
treebc46c04cbdea39be6c2301f20332725a6c5dc59d /dev-python/picobox/picobox-2.2.0.ebuild
parentdev-python/sphinxcontrib_github_alt: new package, 1.2 (diff)
downloadgentoo-c26b34c92ffa6e64783067266d1885ddd3ba22e9.tar.gz
gentoo-c26b34c92ffa6e64783067266d1885ddd3ba22e9.tar.bz2
gentoo-c26b34c92ffa6e64783067266d1885ddd3ba22e9.zip
dev-python/picobox: new package, 2.2.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/picobox/picobox-2.2.0.ebuild')
-rw-r--r--dev-python/picobox/picobox-2.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/picobox/picobox-2.2.0.ebuild b/dev-python/picobox/picobox-2.2.0.ebuild
new file mode 100644
index 000000000000..5a25c40a8670
--- /dev/null
+++ b/dev-python/picobox/picobox-2.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Dependency injection framework designed with Python in mind"
+HOMEPAGE="https://pypi.org/project/picobox/
+ https://github.com/ikalnytskyi/picobox"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
+
+distutils_enable_tests pytest