summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-19 11:45:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-19 11:46:13 +0100
commit3ec0114c77f11fcd09acaa9bcf8afd9e09a9a557 (patch)
tree7f434aaa0ca1ee69728b35acf5f7aaa30c4bf9cb /dev-python/pid
parentdev-lang/go: marked ~x64-solaris (diff)
downloadgentoo-3ec0114c77f11fcd09acaa9bcf8afd9e09a9a557.tar.gz
gentoo-3ec0114c77f11fcd09acaa9bcf8afd9e09a9a557.tar.bz2
gentoo-3ec0114c77f11fcd09acaa9bcf8afd9e09a9a557.zip
dev-python/pid: initial import; ebuild by me
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/pid')
-rw-r--r--dev-python/pid/Manifest1
-rw-r--r--dev-python/pid/metadata.xml13
-rw-r--r--dev-python/pid/pid-2.0.1.ebuild26
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pid/Manifest b/dev-python/pid/Manifest
new file mode 100644
index 000000000000..d0cf9b9b1bd1
--- /dev/null
+++ b/dev-python/pid/Manifest
@@ -0,0 +1 @@
+DIST pid-2.0.1.tar.gz 9373 SHA256 054cde9c64b8ac979ec27f714e71ebb97ecf8388ea5fe29f6b93db222e92d433 SHA512 10dcded5b52c415a2fa653afdd85e5fbb06433149eee63f306ff84f225086492048db0341bf3a6e448d0654ba4c02afdb72343c0b111bc9682f2248cc4c3817a WHIRLPOOL 801386fcb80d5a7b16793cc5fd9eb6622aa303d7f8be5142f3fd10dc0453ab573b227e06a9b35dc8f3048b5019017db395c40b8c5fce65b086354cfde4853024
diff --git a/dev-python/pid/metadata.xml b/dev-python/pid/metadata.xml
new file mode 100644
index 000000000000..fca014d2e617
--- /dev/null
+++ b/dev-python/pid/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pid/pid-2.0.1.ebuild b/dev-python/pid/pid-2.0.1.ebuild
new file mode 100644
index 000000000000..6e0114e59e29
--- /dev/null
+++ b/dev-python/pid/pid-2.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pidfile featuring stale detection and file-locking"
+HOMEPAGE="https://pypi.python.org/pypi/pid https://github.com/trbs/pid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die
+}