summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-24 23:28:04 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-24 23:29:11 -0500
commitbf61c35c5965e49b6144feadc5d0a7d2601540ae (patch)
tree302fb591ba73bd1df37c2313e66fbe7395fb9982 /dev-python/pika-pool/pika-pool-0.1.3.ebuild
parentdev-python/pika: adding python3 (diff)
downloadgentoo-bf61c35c5965e49b6144feadc5d0a7d2601540ae.tar.gz
gentoo-bf61c35c5965e49b6144feadc5d0a7d2601540ae.tar.bz2
gentoo-bf61c35c5965e49b6144feadc5d0a7d2601540ae.zip
dev-python/pika-pool: adding for openstack mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/pika-pool/pika-pool-0.1.3.ebuild')
-rw-r--r--dev-python/pika-pool/pika-pool-0.1.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pika-pool/pika-pool-0.1.3.ebuild b/dev-python/pika-pool/pika-pool-0.1.3.ebuild
new file mode 100644
index 000000000000..27e18dd85b38
--- /dev/null
+++ b/dev-python/pika-pool/pika-pool-0.1.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A connection pool for pika."
+HOMEPAGE="https://github.com/bninja/pika-pool"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/pika-0.9[${PYTHON_USEDEP}]
+ <dev-python/pika-0.11[${PYTHON_USEDEP}]"