summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Gstädtner <thomas@gstaedtner.net>2017-11-12 14:31:16 +0100
committerJonas Stein <jstein@gentoo.org>2017-11-12 20:22:06 +0100
commit592f68ce76daf89e6ea445b9c3f4303a5c722a73 (patch)
tree4f927cb133c39c203c2063f2636eb453099305ca /dev-python/pilkit/pilkit-2.0.ebuild
parentprofiles/arch/arm: drop python3_5 from use.stable.mask (diff)
downloadgentoo-592f68ce76daf89e6ea445b9c3f4303a5c722a73.tar.gz
gentoo-592f68ce76daf89e6ea445b9c3f4303a5c722a73.tar.bz2
gentoo-592f68ce76daf89e6ea445b9c3f4303a5c722a73.zip
dev-python/pilkit: new package
Add new package dev-python/pilkit to the tree. Closes: https://bugs.gentoo.org/637230 Thanks-to: Thomas Deutschmann whissi@gentoo.org Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-python/pilkit/pilkit-2.0.ebuild')
-rw-r--r--dev-python/pilkit/pilkit-2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pilkit/pilkit-2.0.ebuild b/dev-python/pilkit/pilkit-2.0.ebuild
new file mode 100644
index 000000000000..b55d51a92e54
--- /dev/null
+++ b/dev-python/pilkit/pilkit-2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of utilities and processors for the Python Imaging Libary"
+HOMEPAGE="https://github.com/matthewwithanm/pilkit"
+SRC_URI="https://github.com/matthewwithanm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ nosetests --verbose || die
+}