summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-31 09:17:16 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-31 09:31:26 +0100
commitce90f1cf81154f8c0dda353bf6a3ddeaf1249dc3 (patch)
tree0b98a9208301770d484463a36b71630bb153b0bd /dev-python/pip
parentdev-python/pygresql: Bump to 5.2.3 (diff)
downloadgentoo-ce90f1cf81154f8c0dda353bf6a3ddeaf1249dc3.tar.gz
gentoo-ce90f1cf81154f8c0dda353bf6a3ddeaf1249dc3.tar.bz2
gentoo-ce90f1cf81154f8c0dda353bf6a3ddeaf1249dc3.zip
dev-python/pip: Fix accidentally installing virtualenv w/ USE=test
Closes: https://bugs.gentoo.org/832402 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/pip-21.3.1-r1.ebuild2
-rw-r--r--dev-python/pip/pip-22.0.1.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/pip/pip-21.3.1-r1.ebuild b/dev-python/pip/pip-21.3.1-r1.ebuild
index 3516e72b4f8a..8b39334f4fc3 100644
--- a/dev-python/pip/pip-21.3.1-r1.ebuild
+++ b/dev-python/pip/pip-21.3.1-r1.ebuild
@@ -113,6 +113,8 @@ python_test() {
pushd "${WORKDIR}/virtualenv-${VENV_PV}" >/dev/null || die
distutils_install_for_testing
popd >/dev/null || die
+ # prevent it from being installed
+ rm -r "${BUILD_DIR}"/lib/virtualenv* || die
local -x GENTOO_PIP_TESTING=1 \
PATH="${TEST_DIR}/scripts:${PATH}" \
diff --git a/dev-python/pip/pip-22.0.1.ebuild b/dev-python/pip/pip-22.0.1.ebuild
index 598e0beb128f..48c8736f6a40 100644
--- a/dev-python/pip/pip-22.0.1.ebuild
+++ b/dev-python/pip/pip-22.0.1.ebuild
@@ -112,6 +112,8 @@ python_test() {
pushd "${WORKDIR}/virtualenv-${VENV_PV}" >/dev/null || die
distutils_install_for_testing
popd >/dev/null || die
+ # prevent it from being installed
+ rm -r "${BUILD_DIR}"/lib/virtualenv* || die
local -x GENTOO_PIP_TESTING=1 \
PATH="${TEST_DIR}/scripts:${PATH}" \