summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 20:59:10 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 21:43:13 +0100
commit7873d92102062543e53385ee97ec8f493f468ae1 (patch)
tree459dc4b18424f6d706505f09dc7e5a0218933f9c /dev-python/pivy
parentdev-python/plyr: Switch to PEP 517 build (diff)
downloadgentoo-7873d92102062543e53385ee97ec8f493f468ae1.tar.gz
gentoo-7873d92102062543e53385ee97ec8f493f468ae1.tar.bz2
gentoo-7873d92102062543e53385ee97ec8f493f468ae1.zip
dev-python/pivy: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pivy')
-rw-r--r--dev-python/pivy/pivy-0.6.6-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pivy/pivy-0.6.6-r1.ebuild b/dev-python/pivy/pivy-0.6.6-r1.ebuild
new file mode 100644
index 000000000000..33d81867ad25
--- /dev/null
+++ b/dev-python/pivy/pivy-0.6.6-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Coin3D bindings for Python"
+HOMEPAGE="https://github.com/coin3d/pivy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ PIVY_REPO_URI="https://github.com/coin3d/pivy.git"
+else
+ SRC_URI="https://github.com/coin3d/pivy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="+quarter soqt"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( quarter soqt )
+"
+
+RDEPEND="
+ >=media-libs/coin-4.0.0
+ quarter? ( media-libs/quarter )
+ soqt? ( >=media-libs/SoQt-1.6.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/swig
+ dev-util/cmake
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-0001-fix-CMakeLists.txt-for-distutils_cmake.patch
+ "${FILESDIR}"/${P}-0002-Gentoo-specific-clear-swig-deprecation-warning.patch
+)
+
+DOCS=( AUTHORS HACKING NEWS README.md THANKS )