summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-04-10 11:12:38 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-04-10 15:28:52 +0200
commitfb2447cf50b561a3a7d9381f1cecb4ffbb269a7a (patch)
tree4cf1b41ae1ee213bef43e225092ebe7a5d1774d0 /dev-python/pivy
parentwww-client/vivaldi-snapshot: Drop old 3.7.2218.42 (diff)
downloadgentoo-fb2447cf50b561a3a7d9381f1cecb4ffbb269a7a.tar.gz
gentoo-fb2447cf50b561a3a7d9381f1cecb4ffbb269a7a.tar.bz2
gentoo-fb2447cf50b561a3a7d9381f1cecb4ffbb269a7a.zip
dev-python/pivy: bump to 0.6.6
Closes: https://bugs.gentoo.org/780117 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/20326 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-python/pivy')
-rw-r--r--dev-python/pivy/Manifest1
-rw-r--r--dev-python/pivy/files/pivy-0.6.6-0001-fix-CMakeLists.txt-for-distutils_cmake.patch24
-rw-r--r--dev-python/pivy/files/pivy-0.6.6-0002-Gentoo-specific-clear-swig-deprecation-warning.patch26
-rw-r--r--dev-python/pivy/pivy-0.6.6.ebuild47
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/pivy/Manifest b/dev-python/pivy/Manifest
index 3b1437a5bd10..49189d75a6a5 100644
--- a/dev-python/pivy/Manifest
+++ b/dev-python/pivy/Manifest
@@ -1 +1,2 @@
DIST pivy-0.6.5.tar.gz 6614159 BLAKE2B 2652feb26137b2deda8b76083d3bd9018303ca0a0236ea97e83e9ff24ddeda30462a25ac1b20b0d3e718fc9f83ae5ebf7116a5c0d94debcc5b6d729792230655 SHA512 6cf0b1ac348336609f42f6a72df7ffdc3e1042a4f8fc6e2b725ca38f09476c70bafa14c1f083d1badeb5b37b974a0fbf5806ea71d44d734b9ab9b125ce7f8695
+DIST pivy-0.6.6.tar.gz 6618471 BLAKE2B 5bcf2479bf26628e3dfe59c1440901368442de2f32a5680ef1af10d49239d8c73b79809495d7227937fd7784af1e1ded27f93f0255793e713add0c1cc35b8e5d SHA512 e260c6abd0aede7621d5fed66eeceb98a32634af84370ef713d70d583ec017cded4be682fd7e70e5faa19988a5e032a9d2f2308b8ae6dd9495d76e884de1d80c
diff --git a/dev-python/pivy/files/pivy-0.6.6-0001-fix-CMakeLists.txt-for-distutils_cmake.patch b/dev-python/pivy/files/pivy-0.6.6-0001-fix-CMakeLists.txt-for-distutils_cmake.patch
new file mode 100644
index 000000000000..a2e97027b586
--- /dev/null
+++ b/dev-python/pivy/files/pivy-0.6.6-0001-fix-CMakeLists.txt-for-distutils_cmake.patch
@@ -0,0 +1,24 @@
+From 44e8dd5b2252c7639021506202df60d6664153d7 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Sat, 10 Apr 2021 10:27:55 +0200
+Subject: [PATCH] fix CMakeLists.txt for distutils_cmake
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+---
+ distutils_cmake/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/distutils_cmake/CMakeLists.txt b/distutils_cmake/CMakeLists.txt
+index 976be6a..ccc54e4 100644
+--- a/distutils_cmake/CMakeLists.txt
++++ b/distutils_cmake/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ cmake_minimum_required(VERSION 3.5)
+-project(pivy_cmake_setup NONE)
++project(pivy_cmake_setup)
+
+
+ find_package(Coin CONFIG REQUIRED)
+--
+2.31.1
+
diff --git a/dev-python/pivy/files/pivy-0.6.6-0002-Gentoo-specific-clear-swig-deprecation-warning.patch b/dev-python/pivy/files/pivy-0.6.6-0002-Gentoo-specific-clear-swig-deprecation-warning.patch
new file mode 100644
index 000000000000..f3e7c8f0fd70
--- /dev/null
+++ b/dev-python/pivy/files/pivy-0.6.6-0002-Gentoo-specific-clear-swig-deprecation-warning.patch
@@ -0,0 +1,26 @@
+From 8fd388dd17f8bfa7df62cbea86d077c1d0d0cb66 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Sat, 10 Apr 2021 10:49:57 +0200
+Subject: [PATCH] [Gentoo-specific] clear swig deprecation warning
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 14f0f1b..b1f9a8f 100755
+--- a/setup.py
++++ b/setup.py
+@@ -144,7 +144,7 @@ class pivy_build(build):
+ SWIG = ((sys.platform == "win32" and "swig.exe") or "swig")
+
+ SWIG_SUPPRESS_WARNINGS = "-w302,306,307,312,314,325,361,362,467,389,503,509,510"
+- SWIG_PARAMS = "-c++ -python -includeall -modern -D__PIVY__ " + \
++ SWIG_PARAMS = "-c++ -python -includeall -D__PIVY__ " + \
+ "-I. -Ifake_headers -I\"%s\" %s -o %s_wrap.cpp " + \
+ "interfaces" + os.sep + "%s.i"
+ if sys.version_info.major >= 3:
+--
+2.31.1
+
diff --git a/dev-python/pivy/pivy-0.6.6.ebuild b/dev-python/pivy/pivy-0.6.6.ebuild
new file mode 100644
index 000000000000..840079762e22
--- /dev/null
+++ b/dev-python/pivy/pivy-0.6.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Coin3D bindings for Python"
+HOMEPAGE="https://github.com/coin3d/pivy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ PIVY_REPO_URI="https://github.com/coin3d/pivy.git"
+else
+ SRC_URI="https://github.com/coin3d/pivy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="+quarter soqt"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( quarter soqt )
+"
+
+RDEPEND="
+ >=media-libs/coin-4.0.0
+ quarter? ( media-libs/quarter )
+ soqt? ( >=media-libs/SoQt-1.6.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/swig
+ dev-util/cmake
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-0001-fix-CMakeLists.txt-for-distutils_cmake.patch
+ "${FILESDIR}"/${P}-0002-Gentoo-specific-clear-swig-deprecation-warning.patch
+)
+
+DOCS=( AUTHORS HACKING NEWS README.md THANKS )