summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-02-24 17:29:09 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-02-24 18:05:06 -0800
commit05529d9cfd25259280a93c382d99ea7009681aca (patch)
tree1adbe50138e6028264c84895473a7ee473aa500b /dev-python/pkgconfig/pkgconfig-1.5.1.ebuild
parentdev-python/isodate-0.6.0-r1: revbump, EAPI=7, py37 (diff)
downloadgentoo-05529d9cfd25259280a93c382d99ea7009681aca.tar.gz
gentoo-05529d9cfd25259280a93c382d99ea7009681aca.tar.bz2
gentoo-05529d9cfd25259280a93c382d99ea7009681aca.zip
dev-python/pkgconfig-1.5.1: Bump, add py38
Had to drop arm64 keyword due to pyproject2setuppy dependency. Will be included in a to-be-filed keywording bug. Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pkgconfig/pkgconfig-1.5.1.ebuild')
-rw-r--r--dev-python/pkgconfig/pkgconfig-1.5.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pkgconfig/pkgconfig-1.5.1.ebuild b/dev-python/pkgconfig/pkgconfig-1.5.1.ebuild
new file mode 100644
index 000000000000..2ea65fc4eef4
--- /dev/null
+++ b/dev-python/pkgconfig/pkgconfig-1.5.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Interface Python with pkg-config"
+HOMEPAGE="https://pypi.org/project/pkgconfig/ https://github.com/matze/pkgconfig"
+SRC_URI="https://github.com/matze/pkgconfig/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="virtual/pkgconfig"
+
+distutils_enable_tests pytest