summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-17 09:45:44 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-17 09:55:26 +0100
commit246bd92f15868c240c30fec646ca8e16a259a01d (patch)
tree5b6006bcccc2e27fa0028e512ed0fc70a9569a85 /dev-python/pkginfo/pkginfo-1.7.0.ebuild
parentdev-python/setuptools: Bump to 51.3.1 (diff)
downloadgentoo-246bd92f15868c240c30fec646ca8e16a259a01d.tar.gz
gentoo-246bd92f15868c240c30fec646ca8e16a259a01d.tar.bz2
gentoo-246bd92f15868c240c30fec646ca8e16a259a01d.zip
dev-python/pkginfo: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pkginfo/pkginfo-1.7.0.ebuild')
-rw-r--r--dev-python/pkginfo/pkginfo-1.7.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pkginfo/pkginfo-1.7.0.ebuild b/dev-python/pkginfo/pkginfo-1.7.0.ebuild
new file mode 100644
index 000000000000..a1a0c45ada8b
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.7.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="https://pypi.org/project/pkginfo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests nose
+distutils_enable_sphinx docs
+
+src_prepare() {
+ # TODO
+ sed -i -e 's:test_ctor_w_package_no_PKG_INFO:_&:' \
+ pkginfo/tests/test_installed.py || die
+ distutils-r1_src_prepare
+}