summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-16 09:00:02 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-16 09:10:08 +0200
commit3f7469ccc9689b08824d6760de7a0a15ac479cad (patch)
tree0940cfb94e3ce87711079ba4cca52825f234141b /dev-python/platformdirs/platformdirs-2.0.2.ebuild
parentwww-apps/hugo: Remove old ebuild (diff)
downloadgentoo-3f7469ccc9689b08824d6760de7a0a15ac479cad.tar.gz
gentoo-3f7469ccc9689b08824d6760de7a0a15ac479cad.tar.bz2
gentoo-3f7469ccc9689b08824d6760de7a0a15ac479cad.zip
dev-python/platformdirs: Another NIH dep of dev-python/virtualenv
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/platformdirs/platformdirs-2.0.2.ebuild')
-rw-r--r--dev-python/platformdirs/platformdirs-2.0.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/platformdirs/platformdirs-2.0.2.ebuild b/dev-python/platformdirs/platformdirs-2.0.2.ebuild
new file mode 100644
index 000000000000..854f3231a6f5
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-2.0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/"
+SRC_URI="
+ https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/appdirs[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest