summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-03 07:27:57 +0100
committerSam James <sam@gentoo.org>2022-06-03 07:28:33 +0100
commitc818c56789749aec547a0df6d82e522b4146a87b (patch)
treec647c41eaad351ecc65eed708a53f730cac4ff45 /dev-python/plotly
parentdev-ruby/rack: add 2.2.3.1 (diff)
downloadgentoo-c818c56789749aec547a0df6d82e522b4146a87b.tar.gz
gentoo-c818c56789749aec547a0df6d82e522b4146a87b.tar.bz2
gentoo-c818c56789749aec547a0df6d82e522b4146a87b.zip
dev-python/plotly: add 5.8.0
Closes: https://bugs.gentoo.org/841002 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/plotly')
-rw-r--r--dev-python/plotly/Manifest1
-rw-r--r--dev-python/plotly/files/plotly-5.8.0-fix-versioneer-import.patch14
-rw-r--r--dev-python/plotly/plotly-5.8.0.ebuild63
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/plotly/Manifest b/dev-python/plotly/Manifest
index 6b7240b0df5e..cdbf1b6f15c2 100644
--- a/dev-python/plotly/Manifest
+++ b/dev-python/plotly/Manifest
@@ -1,2 +1,3 @@
DIST plotly-5.2.2.tar.gz 7293292 BLAKE2B baef3accf8f5a3085908fcea558f8003687e18a1f97471c620c378c10d23d4222ef87dc47d64f45199b594414890db5b8ca5e3d7867c871d926c2ae441128c4a SHA512 4d6d79f7cc2063e73e7c17ff90a7d13324497ea8034d8ce62d79ec62b0530a59b2eaec8913fb05efb804cf5be8387b6f96d1710f41b9993233b5a13cf64dd310
DIST plotly-5.7.0.tar.gz 8609793 BLAKE2B 12318f837c248c54fd3a8723bc772e8348186942565ba5a4c095f348dc338cc098318889900500ec333d7ec352801926ec91d312f2ccd98a89f804159223057f SHA512 01675470ef5218f06b4e9e485f23155a8e8550748fdf86afdb2a2969f838464b70d4452811427ab6bed2846093e8cfba7e891f7d0ea3a621e1fbffe22182d933
+DIST plotly-5.8.0.tar.gz 7573157 BLAKE2B 522d0d22d29d5ee204a9ecccbfe7862acee8b8605ab3dfce46a7b771020c24aff39b74aa3244c8384d61bb7e61ca5d2a610d061b0c208bf6cf9fe91543bbfc3f SHA512 2c17c97e897959a9826c19495c30cc7dd21de80e777c13927c1f47c3aa08f64f53ad715d156e78aabaf99fa2a8f85c90d63b08a227c5301710b5c561ee89429c
diff --git a/dev-python/plotly/files/plotly-5.8.0-fix-versioneer-import.patch b/dev-python/plotly/files/plotly-5.8.0-fix-versioneer-import.patch
new file mode 100644
index 000000000000..4d0411a34c62
--- /dev/null
+++ b/dev-python/plotly/files/plotly-5.8.0-fix-versioneer-import.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/841002
+https://github.com/dandi/dandi-cli/pull/998
+https://github.com/mgorny/gpep517/issues/1
+--- a/setup.py
++++ b/setup.py
+@@ -11,7 +11,7 @@ from distutils import log
+ # ensure the current directory is on sys.path; so versioneer can be imported
+ # when pip uses PEP 517/518 build rules.
+ # https://github.com/python-versioneer/python-versioneer/issues/193
+-sys.path.append(os.path.dirname(__file__))
++sys.path.insert(0, os.path.dirname(__file__))
+
+ import versioneer
+
diff --git a/dev-python/plotly/plotly-5.8.0.ebuild b/dev-python/plotly/plotly-5.8.0.ebuild
new file mode 100644
index 000000000000..727c95cffca9
--- /dev/null
+++ b/dev-python/plotly/plotly-5.8.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plotly.com/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# TODO: package plotly-orca and kaleido
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/tenacity-6.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/backports-tempfile[${PYTHON_USEDEP}]
+ ' 3.8)
+ dev-python/inflect[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/jupyter[${PYTHON_USEDEP}]
+ dev-python/jupyterlab[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ sci-libs/pyshp[${PYTHON_USEDEP}]
+ sci-libs/scikit-image[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.8.0-fix-versioneer-import.patch
+)
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ mkdir -p "${ED}"/etc/ || die
+ mv "${ED}"/usr/etc/jupyter "${ED}"/etc/ || die
+ rmdir "${ED}"/usr/etc || die
+}