summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-02-24 01:41:35 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-02-24 04:20:59 +0100
commit0a7bd2580410d78ffbfae66fc1ac8268120a8917 (patch)
treeecef75e182530ac146803b73ecd7f4eeb82b0d16 /dev-python/pluggy/pluggy-0.6.0.ebuild
parentnet-misc/ntpsec: fix config files and remove strip executables (diff)
downloadgentoo-0a7bd2580410d78ffbfae66fc1ac8268120a8917.tar.gz
gentoo-0a7bd2580410d78ffbfae66fc1ac8268120a8917.tar.bz2
gentoo-0a7bd2580410d78ffbfae66fc1ac8268120a8917.zip
dev-python/pluggy: Bump to v0.6.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/pluggy/pluggy-0.6.0.ebuild')
-rw-r--r--dev-python/pluggy/pluggy-0.6.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pluggy/pluggy-0.6.0.ebuild b/dev-python/pluggy/pluggy-0.6.0.ebuild
new file mode 100644
index 000000000000..09df42b74198
--- /dev/null
+++ b/dev-python/pluggy/pluggy-0.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE="https://pluggy.readthedocs.io/ https://github.com/pytest-dev/pluggy https://pypi.python.org/pypi/pluggy"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "tests failed with ${EPYTHON}"
+}