summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-12-15 16:29:13 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-12-15 16:29:13 +0700
commit459279976eb06d9ecc07fdea3e57f336018e2f2a (patch)
tree1ae3c631dea27ae5fc3dd2db7479b55d002b1cd5 /dev-python/plumbum
parentdev-python/BitVector: bump to 3.4.7 (diff)
downloadgentoo-459279976eb06d9ecc07fdea3e57f336018e2f2a.tar.gz
gentoo-459279976eb06d9ecc07fdea3e57f336018e2f2a.tar.bz2
gentoo-459279976eb06d9ecc07fdea3e57f336018e2f2a.zip
dev-python/plumbum: bump to 1.6.4
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-python/plumbum')
-rw-r--r--dev-python/plumbum/Manifest1
-rw-r--r--dev-python/plumbum/files/plumbum-1.6.4.patch35
-rw-r--r--dev-python/plumbum/plumbum-1.6.4.ebuild17
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/plumbum/Manifest b/dev-python/plumbum/Manifest
index b5c7d9db5fab..79ac4cbc7412 100644
--- a/dev-python/plumbum/Manifest
+++ b/dev-python/plumbum/Manifest
@@ -1,2 +1,3 @@
DIST plumbum-1.6.0.tar.gz 77092 BLAKE2B 795101098614dfe547e884fb3c4f9e7947a65995a5223d89a83aedd91ed7d4eac25dd926d022e32384430620561128f9e957d05af68c463a65b58e8a86ce2717 SHA512 0be9461720cb03c56aff8f56705b1753013e02df4b4d3dbc7e8379930b9efb3822df587483ca708f3a16f08d625f03459f8fe377bc50e59439d05f73669003cc
DIST plumbum-1.6.3.tar.gz 82109 BLAKE2B 363b0f779838fb341f67aaaf60f037cf978813ea10b5f3f4c0eb7cfe8360e64e75678740c8c0a669466f31075079de4d7e9b4e7dc90374faf52671689cc7bbbb SHA512 998148db310d3ede1a641bd0e8875a5b3853a08329d5bc68eea163f9eaa1e0e05548f544084d72ad2d233fd9b9bd1ed7518b0f8047e0e737a7a014fa0cd8fe1f
+DIST plumbum-1.6.4.tar.gz 88041 BLAKE2B aadd929fc6878bd49ac3169b1b4235140d08ff452eb5eb61e43f9ad869ea867916d76ee7f2befb68e67cdd9d9b19c364d6e02810866f6ba5022cf7064d240786 SHA512 26110741251d75ae9b47f522aba38e8af7a658d22900b1487b3f6e4e6971e4682283003e674f40345e14dd4103f6d485fc569348cc1245ac0440cd04688abe99
diff --git a/dev-python/plumbum/files/plumbum-1.6.4.patch b/dev-python/plumbum/files/plumbum-1.6.4.patch
new file mode 100644
index 000000000000..ce18d7afe09d
--- /dev/null
+++ b/dev-python/plumbum/files/plumbum-1.6.4.patch
@@ -0,0 +1,35 @@
+diff -r -U2 plumbum-1.6.4.orig/plumbum/cli/image.py plumbum-1.6.4/plumbum/cli/image.py
+--- plumbum-1.6.4.orig/plumbum/cli/image.py 2017-11-08 21:20:49.000000000 +0700
++++ plumbum-1.6.4/plumbum/cli/image.py 2017-12-15 15:45:16.184943092 +0700
+@@ -3,5 +3,6 @@
+ from plumbum import colors
+ from .termsize import get_terminal_size
+-import . as cli
++from .application import Application
++from .switches import switch, SwitchAttr, Flag, positional, Range, ExistingFile
+ import sys
+
+@@ -75,17 +76,17 @@
+ print(colors.reset)
+
+-class ShowImageApp(cli.Application):
++class ShowImageApp(Application):
+ 'Display an image on the terminal'
+- double = cli.Flag(['-d','--double'], help="Double resolution (only looks good with some fonts)")
++ double = Flag(['-d','--double'], help="Double resolution (only looks good with some fonts)")
+
+- @cli.switch(['-c','--colors'], cli.Range(1,4), help="Level of color, 1-4")
++ @switch(['-c','--colors'], Range(1,4), help="Level of color, 1-4")
+ def colors_set(self, n):
+ colors.use_color = n
+
+- size = cli.SwitchAttr(['-s','--size'], help="Size, should be in the form 100x150")
++ size = SwitchAttr(['-s','--size'], help="Size, should be in the form 100x150")
+
+- ratio = cli.SwitchAttr(['--ratio'], float, default=2.45, help="Aspect ratio of the font")
++ ratio = SwitchAttr(['--ratio'], float, default=2.45, help="Aspect ratio of the font")
+
+- @cli.positional(cli.ExistingFile)
++ @positional(ExistingFile)
+ def main(self, filename):
+
diff --git a/dev-python/plumbum/plumbum-1.6.4.ebuild b/dev-python/plumbum/plumbum-1.6.4.ebuild
new file mode 100644
index 000000000000..8ad4fd785674
--- /dev/null
+++ b/dev-python/plumbum/plumbum-1.6.4.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A library for shell script-like programs in python"
+HOMEPAGE="http://plumbum.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+PATCHES=( "${FILESDIR}"/${P}.patch )