summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ply
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ply')
-rw-r--r--dev-python/ply/Manifest2
-rw-r--r--dev-python/ply/files/3.6-lextab-None.patch49
-rw-r--r--dev-python/ply/files/3.6-picklefile-IOError.patch24
-rw-r--r--dev-python/ply/metadata.xml18
-rw-r--r--dev-python/ply/ply-3.4-r1.ebuild41
-rw-r--r--dev-python/ply/ply-3.6-r1.ebuild45
6 files changed, 179 insertions, 0 deletions
diff --git a/dev-python/ply/Manifest b/dev-python/ply/Manifest
new file mode 100644
index 000000000000..164ee420f947
--- /dev/null
+++ b/dev-python/ply/Manifest
@@ -0,0 +1,2 @@
+DIST ply-3.4.tar.gz 138342 SHA256 af435f11b7bdd69da5ffbc3fecb8d70a7073ec952e101764c88720cdefb2546b SHA512 6f6ee528393ff83eff2530ca468caf12e4c89b817a38302738597f1478dd41758036c8f32f88f60d1a26e70d9cfceab5530ddcfd3f058c1ee722be95c27e6bcc WHIRLPOOL f2f58e2d0c1170d35554999ca643c102d6821a7535b5782ee7317a4100cf56b5648d643c274cefd66a7b484ae3a9e952bcf4b98d50e7fd1ff220853f982a2f4c
+DIST ply-3.6.tar.gz 281690 SHA256 61367b9eb2f4b819f69ea116750305270f1df8859992c9e356d6a851f25a4b47 SHA512 1a408d7cd4cdc9d747154623672e6baaf37ad2190cb9d6d6a7c1e1cc3cb40f15547734441b8fc99ecd67d7804d767576bdf0ed219cc669bf3d0df37498c55c55 WHIRLPOOL 2868a0046519750a446b683a85966650407afc1ea32ab6d8209b46b280529ca6aa8c47816782020b4c90f6f92d4733dd07565b6518e20c7a036d743edc629496
diff --git a/dev-python/ply/files/3.6-lextab-None.patch b/dev-python/ply/files/3.6-lextab-None.patch
new file mode 100644
index 000000000000..cab0a466d66f
--- /dev/null
+++ b/dev-python/ply/files/3.6-lextab-None.patch
@@ -0,0 +1,49 @@
+From dbf122652d38ba03ff9f9fe4aa9bee3693e6775f Mon Sep 17 00:00:00 2001
+From: David Beazley <dave@dabeaz.com>
+Date: Fri, 8 May 2015 10:10:55 -0500
+Subject: [PATCH] Minor fix to account for bad None arguments for
+ tabmodule/lextab
+
+---
+ ply/lex.py | 4 ++++
+ ply/yacc.py | 5 ++++-
+ 2 files changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/ply/lex.py b/ply/lex.py
+index ed1e2ed..772325c 100644
+--- a/ply/lex.py
++++ b/ply/lex.py
+@@ -859,6 +859,10 @@ def validate_module(self, module):
+ # -----------------------------------------------------------------------------
+ def lex(module=None, object=None, debug=False, optimize=False, lextab='lextab',
+ reflags=0, nowarn=False, outputdir=None, debuglog=None, errorlog=None):
++
++ if lextab is None:
++ lextab = 'lextab'
++
+ global lexer
+
+ ldict = None
+diff --git a/ply/yacc.py b/ply/yacc.py
+index e0b4faf..eb02cc2 100644
+--- a/ply/yacc.py
++++ b/ply/yacc.py
+@@ -2709,7 +2709,7 @@ def write_table(self, tabmodule, outputdir='', signature=''):
+ _lr_method = %r
+
+ _lr_signature = %r
+- ''' % (filename, __tabversion__, self.lr_method, signature))
++ ''' % (os.path.basename(filename), __tabversion__, self.lr_method, signature))
+
+ # Change smaller to 0 to go back to original tables
+ smaller = 1
+@@ -3183,6 +3183,9 @@ def yacc(method='LALR', debug=yaccdebug, module=None, tabmodule=tab_module, star
+ check_recursion=True, optimize=False, write_tables=True, debugfile=debug_file,
+ outputdir=None, debuglog=None, errorlog=None, picklefile=None):
+
++ if tabmodule is None:
++ tabmodule = tab_module
++
+ # Reference to the parsing method of the last built parser
+ global parse
+
diff --git a/dev-python/ply/files/3.6-picklefile-IOError.patch b/dev-python/ply/files/3.6-picklefile-IOError.patch
new file mode 100644
index 000000000000..85b39494a6fd
--- /dev/null
+++ b/dev-python/ply/files/3.6-picklefile-IOError.patch
@@ -0,0 +1,24 @@
+From f50768b0b2176998675e728d84ac05f0eef19614 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Sun, 17 May 2015 12:14:16 -0400
+Subject: [PATCH] Catch/ignore IOError when opening picklefile for reading in
+ yacc.yacc()
+
+Should resolve #66.
+---
+ ply/yacc.py | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/ply/yacc.py b/ply/yacc.py
+index eb02cc2..2835c90 100644
+--- a/ply/yacc.py
++++ b/ply/yacc.py
+@@ -3265,6 +3265,8 @@ def yacc(method='LALR', debug=yaccdebug, module=None, tabmodule=tab_module, star
+ errorlog.warning(str(e))
+ except ImportError:
+ pass
++ except IOError:
++ pass
+
+ if debuglog is None:
+ if debug:
diff --git a/dev-python/ply/metadata.xml b/dev-python/ply/metadata.xml
new file mode 100644
index 000000000000..57a9a959420f
--- /dev/null
+++ b/dev-python/ply/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription>
+PLY is a Python-only implementation of the popular compiler construction
+tools lex and yacc. The implementation borrows ideas from a number of
+previous efforts; most notably John Aycock's SPARK toolkit. However,
+the overall flavor of the implementation is more closely modeled after
+the C version of lex and yacc. The other significant feature of PLY is
+that it provides extensive input validation and error reporting--much
+more so than other Python parsing tools.
+</longdescription>
+<longdescription lang="ja">
+PLYはLexとYaccの有名なコンパイラ・コンストラクション・ツールのPython言語実装です
+。この実装は以前の試みから幾つものアイディアを借りています。そのほとんどがJohn AycockのSPARKツールキットからです。しかしながら、実装の全体像はC言語によるLexとYaccにより近いモデルです。PLYの他の重要点は幅広い入力バリデーションとエラー報告を>提供する点です。 -- その二点は他のPython言語パーサーより優れています。
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/ply/ply-3.4-r1.ebuild b/dev-python/ply/ply-3.4-r1.ebuild
new file mode 100644
index 000000000000..816c9961e2ee
--- /dev/null
+++ b/dev-python/ply/ply-3.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Lex-Yacc library"
+HOMEPAGE="http://www.dabeaz.com/ply/ http://pypi.python.org/pypi/ply"
+SRC_URI="http://www.dabeaz.com/ply/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+# See bug #458648 for reference
+RESTRICT="test"
+
+DOCS=( ANNOUNCE CHANGES README TODO )
+
+python_test() {
+ cp -r -l test "${BUILD_DIR}"/ || die
+ cd "${BUILD_DIR}"/test || die
+
+ local t
+ for t in testlex.py testyacc.py; do
+ "${PYTHON}" "${t}" || die "${t} fails with ${EPYTHON}"
+ done
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/ply/ply-3.6-r1.ebuild b/dev-python/ply/ply-3.6-r1.ebuild
new file mode 100644
index 000000000000..e302718f0d72
--- /dev/null
+++ b/dev-python/ply/ply-3.6-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Lex-Yacc library"
+HOMEPAGE="http://www.dabeaz.com/ply/ http://pypi.python.org/pypi/ply"
+SRC_URI="http://www.dabeaz.com/ply/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+# See bug #458648 for reference
+RESTRICT="test"
+
+DOCS=( ANNOUNCE CHANGES TODO )
+PATCHES=(
+ "${FILESDIR}/3.6-lextab-None.patch"
+ "${FILESDIR}/3.6-picklefile-IOError.patch"
+)
+
+python_test() {
+ cp -r -l test "${BUILD_DIR}"/ || die
+ cd "${BUILD_DIR}"/test || die
+
+ local t
+ for t in testlex.py testyacc.py; do
+ "${PYTHON}" "${t}" || die "${t} fails with ${EPYTHON}"
+ done
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}