summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-01-13 10:16:05 +0100
committerIan Delaney <idella4@gentoo.org>2016-01-13 18:31:31 +0800
commit08ffd63ad257f2a69691d30ad9f5fc752a0d86a1 (patch)
treeaac5612b0c813150ad848d6fc626184bb26fe386 /dev-python/plyvel/plyvel-0.9.ebuild
parentnet-misc/ntp: Removed old. (diff)
downloadgentoo-08ffd63ad257f2a69691d30ad9f5fc752a0d86a1.tar.gz
gentoo-08ffd63ad257f2a69691d30ad9f5fc752a0d86a1.tar.bz2
gentoo-08ffd63ad257f2a69691d30ad9f5fc752a0d86a1.zip
dev-python/plyvel: new package: python bindings for LevelDB
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/plyvel/plyvel-0.9.ebuild')
-rw-r--r--dev-python/plyvel/plyvel-0.9.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/plyvel/plyvel-0.9.ebuild b/dev-python/plyvel/plyvel-0.9.ebuild
new file mode 100644
index 000000000000..d99b31d44abd
--- /dev/null
+++ b/dev-python/plyvel/plyvel-0.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Python interface to LevelDB"
+HOMEPAGE="https://github.com/wbolster/plyvel"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-libs/leveldb"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile() {
+ python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake doc
+}
+
+python_test() {
+ local lib="$(ls "${BUILD_DIR}/lib/${PN}/"*.so | head -n1)"
+ ln -s "${lib}" "${PN}" || die
+ py.test || die "tests failed with ${EPYTHON}"
+ rm "${PN}/$(basename "${lib}")" || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build//html/. )
+ distutils-r1_python_install_all
+}
+