summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pmw/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pmw/files')
-rw-r--r--dev-python/pmw/files/1.3.2-python2.5.patch54
-rw-r--r--dev-python/pmw/files/pmw-1.3.2-install-no-docs.patch13
-rw-r--r--dev-python/pmw/files/pmw-1.3.3-install-no-docs.patch17
3 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/pmw/files/1.3.2-python2.5.patch b/dev-python/pmw/files/1.3.2-python2.5.patch
new file mode 100644
index 000000000000..ff8cce07ddaa
--- /dev/null
+++ b/dev-python/pmw/files/1.3.2-python2.5.patch
@@ -0,0 +1,54 @@
+Source: http://github.com/nanotube/pmw_fixes/commit/5e6dcbdaef2bb6c40037b922dd0efa081f1575ab (Daniel Folkinshteyn)
+
+fix bug in OptionMenu.setitems, introduced with the fixing of this python
+bug:
+http://bugs.python.org/issue1342811
+
+versions of python 2.5.4 and newer now automatically delete commands when
+items are deleted
+however, that causes error if the command is deleted manually beforehand.
+old versions, on the contrary, require manual command deletion to free up
+the objects.
+
+so we put in a python version check to see if we need to manually delete
+commands.
+
+fixes the Pmw bug referred to here:
+http://sourceforge.net/forum/forum.php?thread_id=3283195&forum_id=33675
+and here:
+http://sourceforge.net/tracker/?func=detail&aid=2795731&group_id=10743&ati
+d=110743
+
+--- a/src/Pmw/Pmw_1_3/lib/PmwOptionMenu.py
++++ b/src/Pmw/Pmw_1_3/lib/PmwOptionMenu.py
+@@ -1,6 +1,7 @@
+ import types
+ import Tkinter
+ import Pmw
++import sys
+
+ class OptionMenu(Pmw.MegaWidget):
+
+@@ -59,11 +60,17 @@ class OptionMenu(Pmw.MegaWidget):
+
+ def setitems(self, items, index = None):
+
+- # Clean up old items and callback commands.
+- for oldIndex in range(len(self._itemList)):
+- tclCommandName = str(self._menu.entrycget(oldIndex, 'command'))
+- if tclCommandName != '':
+- self._menu.deletecommand(tclCommandName)
++ # python version check
++ # python versions >= 2.5.4 automatically clean commands
++ # and manually cleaning them causes errors when deleting items
++
++ if sys.version_info[0] * 100 + sys.version_info[1] * 10 + \
++ sys.version_info[2] < 254:
++ # Clean up old items and callback commands.
++ for oldIndex in range(len(self._itemList)):
++ tclCommandName = str(self._menu.entrycget(oldIndex, 'command'))
++ if tclCommandName != '':
++ self._menu.deletecommand(tclCommandName)
+ self._menu.delete(0, 'end')
+ self._itemList = list(items)
+
diff --git a/dev-python/pmw/files/pmw-1.3.2-install-no-docs.patch b/dev-python/pmw/files/pmw-1.3.2-install-no-docs.patch
new file mode 100644
index 000000000000..325dc4e2998c
--- /dev/null
+++ b/dev-python/pmw/files/pmw-1.3.2-install-no-docs.patch
@@ -0,0 +1,13 @@
+diff -uNr Pmw.1.3.2.orig/src/setup.py Pmw.1.3.2/src/setup.py
+--- Pmw.1.3.2.orig/src/setup.py 2008-08-02 15:40:19.000000000 -0430
++++ Pmw.1.3.2/src/setup.py 2008-08-02 15:40:36.000000000 -0430
+@@ -16,9 +16,7 @@
+ 'Pmw.Pmw_1_3.lib',],
+
+ package_data={'Pmw': ['Pmw_1_3/lib/Pmw.def',
+- 'Pmw_1_3/doc/*',
+ 'Pmw_1_3/contrib/*',
+- 'Pmw_1_3/demos/*',
+ 'Pmw_1_3/tests/*',
+ 'Pmw_1_3/bin/*',
+ ]
diff --git a/dev-python/pmw/files/pmw-1.3.3-install-no-docs.patch b/dev-python/pmw/files/pmw-1.3.3-install-no-docs.patch
new file mode 100644
index 000000000000..979e24abf59a
--- /dev/null
+++ b/dev-python/pmw/files/pmw-1.3.3-install-no-docs.patch
@@ -0,0 +1,17 @@
+ src/setup.py | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/src/setup.py b/src/setup.py
+index a5f9039..cfcf8a2 100755
+--- a/src/setup.py
++++ b/src/setup.py
+@@ -16,9 +16,7 @@ setup(name="Pmw",
+ 'Pmw.Pmw_1_3_3.lib',],
+
+ package_data={'Pmw': ['Pmw_1_3_3/lib/Pmw.def',
+- 'Pmw_1_3_3/doc/*',
+ 'Pmw_1_3_3/contrib/*',
+- 'Pmw_1_3_3/demos/*',
+ 'Pmw_1_3_3/tests/*',
+ 'Pmw_1_3_3/bin/*',
+ ]