summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-14 08:54:21 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-14 09:31:12 +0200
commit4185ca2c35430baeac88146d6b8459c6ab36723b (patch)
treeb451b3dd48630efb931aa2c38ca888d38904d927 /dev-python/pocketlint
parentdev-python/pyghmi: Bump to 1.5.51 (diff)
downloadgentoo-4185ca2c35430baeac88146d6b8459c6ab36723b.tar.gz
gentoo-4185ca2c35430baeac88146d6b8459c6ab36723b.tar.bz2
gentoo-4185ca2c35430baeac88146d6b8459c6ab36723b.zip
dev-python/pocketlint: Bump to 0.24
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pocketlint')
-rw-r--r--dev-python/pocketlint/Manifest1
-rw-r--r--dev-python/pocketlint/pocketlint-0.24.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pocketlint/Manifest b/dev-python/pocketlint/Manifest
index dfc36c650a9d..4e6ce0b87c3a 100644
--- a/dev-python/pocketlint/Manifest
+++ b/dev-python/pocketlint/Manifest
@@ -1,2 +1,3 @@
DIST pocketlint-0.22.tar.gz 23779 BLAKE2B 3698927cc4a3f6ee6de74d205b5a7f937405e7ce2e9d987e34b35ce209635cab37357d0221a6762deb66350cd2b991420a9b12af2c9e6792f713e5c95dfedb59 SHA512 7ee9e6b969975274e7697d1d16fadaac82fa0a1855401d9f240aaae123831dc32e381dd24f88a3f004ab45df9f0251c408ed8f60a08fe99caf629af617c80ea0
DIST pocketlint-0.23.gh.tar.gz 23854 BLAKE2B 2ff3388b639ba29ae60ccd0013cea9b1f437d03d552c03089c91ba65f4fdf7b6b739ac2b926248bc5738e29cd41fa104d7c2742385cfe7a454841f2ed252b0fa SHA512 36a6f7fbc5b9475a145bc03ccf9a6918e49ed29279913b1bcc7090961bcc842333a4d31b4eb809a7ca7b384e79c186d1e6397c379c1921943ddd49c3c736aaed
+DIST pocketlint-0.24.gh.tar.gz 23875 BLAKE2B b4699d1f0633ed6a3f84b97db972818c00a1d382a48648fd4fe6870f4c54f983fd36366f85a409a99b860f385902a9a05adec63199e35d1264a522a7a3086e31 SHA512 21c4055dd42c244760950b64ec4cd9359fc589014953be6f9296e0265101f098fbe34351e87f92630751fa0055de20281974a04b425f691acc4608cf929d4bf4
diff --git a/dev-python/pocketlint/pocketlint-0.24.ebuild b/dev-python/pocketlint/pocketlint-0.24.ebuild
new file mode 100644
index 000000000000..c6c11e93d7a8
--- /dev/null
+++ b/dev-python/pocketlint/pocketlint-0.24.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Shared code for running pylint against rhinstaller projects"
+HOMEPAGE="
+ https://github.com/rhinstaller/pocketlint/
+ https://pypi.org/project/pocketlint/
+"
+SRC_URI="
+ https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+"