summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 21:01:06 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 21:43:14 +0100
commit8bf3f51eafde30d0ff287e222498d5e0991d4e11 (patch)
tree4edca0981916a53d9e95bdbec28d2bf0a2770566 /dev-python/podcastparser
parentdev-python/pivy: Switch to PEP 517 build (diff)
downloadgentoo-8bf3f51eafde30d0ff287e222498d5e0991d4e11.tar.gz
gentoo-8bf3f51eafde30d0ff287e222498d5e0991d4e11.tar.bz2
gentoo-8bf3f51eafde30d0ff287e222498d5e0991d4e11.zip
dev-python/podcastparser: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/podcastparser')
-rw-r--r--dev-python/podcastparser/podcastparser-0.6.8-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/podcastparser/podcastparser-0.6.8-r1.ebuild b/dev-python/podcastparser/podcastparser-0.6.8-r1.ebuild
new file mode 100644
index 000000000000..45f40808263c
--- /dev/null
+++ b/dev-python/podcastparser/podcastparser-0.6.8-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Podcast parser for the gpodder client"
+HOMEPAGE="https://github.com/gpodder/podcastparser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest