summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-27 08:47:01 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-27 08:49:24 +0100
commitc3fcb1355d154cf52d0860664f766f2b9f9980a5 (patch)
tree7009673637251cf8a06b7949f4e2543abee60e33 /dev-python/polib/polib-1.1.1.ebuild
parentdev-python/ipython: Bump to 7.22.0 (diff)
downloadgentoo-c3fcb1355d154cf52d0860664f766f2b9f9980a5.tar.gz
gentoo-c3fcb1355d154cf52d0860664f766f2b9f9980a5.tar.bz2
gentoo-c3fcb1355d154cf52d0860664f766f2b9f9980a5.zip
dev-python/polib: Bump to 1.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/polib/polib-1.1.1.ebuild')
-rw-r--r--dev-python/polib/polib-1.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/polib/polib-1.1.1.ebuild b/dev-python/polib/polib-1.1.1.ebuild
new file mode 100644
index 000000000000..cbd7097733ac
--- /dev/null
+++ b/dev-python/polib/polib-1.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to manipulate gettext files (.po and .mo files)"
+HOMEPAGE="https://github.com/izimobil/polib https://polib.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+distutils_enable_sphinx docs
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.7-BE-test.patch
+)
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die "Tests failed under ${EPYTHON}"
+}