summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Konotopov <ykonotopov@gmail.com>2016-05-07 09:17:09 +0300
committerIan Delaney <idella4@gentoo.org>2016-05-07 20:10:56 +0800
commitb222d3eac50a8381c9095a4aaa4137e910cfc559 (patch)
tree662c56526439c2a33ba35d848ac768086a4360a4 /dev-python/polib
parentapp-office/libreoffice-bin-debug: amd64 stable, bug #580672 (diff)
downloadgentoo-b222d3eac50a8381c9095a4aaa4137e910cfc559.tar.gz
gentoo-b222d3eac50a8381c9095a4aaa4137e910cfc559.tar.bz2
gentoo-b222d3eac50a8381c9095a4aaa4137e910cfc559.zip
dev-python/polib: version bump, vn. 1.0.7
Closes: https://github.com/gentoo/gentoo/pull/1423 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/polib')
-rw-r--r--dev-python/polib/Manifest1
-rw-r--r--dev-python/polib/polib-1.0.7.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/polib/Manifest b/dev-python/polib/Manifest
index 7d88dccc0d65..81ccbbddfed8 100644
--- a/dev-python/polib/Manifest
+++ b/dev-python/polib/Manifest
@@ -1 +1,2 @@
DIST polib-1.0.4.tar.gz 151634 SHA256 8b3276f75ce2fce9442e27db3ae63d842416e17f0e2095f39ff52dc735e5749a SHA512 a38d57acdaded0371be83825a28f14f178aebdbc0435724f33eebda109adb2b8210e33659ebec88d2d9e98aa60c482d7f8a958ec18f6769fda7a2fb14edd2744 WHIRLPOOL 1fe4e5bbf27444c1a6d7d79c70325078d3b2d15f6a5eb84852ccb080dfee4d03a7f8311127b6f93e1cb23ad633155bf93221317ec3518b1c5d7ec52b79fab87d
+DIST polib-1.0.7.tar.gz 156282 SHA256 43ce60d05ffa442ba9d3c5722193aadb93c38174b9fb471c8ea7ccbf8349bbca SHA512 bfec3538f9ab499ff2149bb40e0685b4cb6d5f0bc7ce8dc33e1fc511a6169e01c1a317e652daed7b3bfd9bbfe6ee1d545b4d8913f54e91504c4debb5b1b94b6e WHIRLPOOL 79bb18cb71d4aba5b6d4b91893cfa043f3df56ae11c4b90b9c8c6a8d3757d1f84bc1a75b1fea462e61907518c042496a422085cb352ae105f25ed11925a4e2cf
diff --git a/dev-python/polib/polib-1.0.7.ebuild b/dev-python/polib/polib-1.0.7.ebuild
new file mode 100644
index 000000000000..e7826f3474ae
--- /dev/null
+++ b/dev-python/polib/polib-1.0.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to manipulate gettext files (.po and .mo files)"
+HOMEPAGE="https://bitbucket.org/izi/polib/wiki/Home"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" tests/tests.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}