summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-25 11:02:39 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-25 11:07:16 +0200
commit19accfa7c587fa6d780780be8ecab7464940da1d (patch)
treed7a1e2c1f1809ea80e12b07ed6edc0b2f46a3604 /dev-python/polygon/polygon-3.0.7.ebuild
parentpackage.mask: Last rite dev-python/nose-descriptionfixer (diff)
downloadgentoo-19accfa7c587fa6d780780be8ecab7464940da1d.tar.gz
gentoo-19accfa7c587fa6d780780be8ecab7464940da1d.tar.bz2
gentoo-19accfa7c587fa6d780780be8ecab7464940da1d.zip
dev-python/polygon: Enable py3.{7,8}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/polygon/polygon-3.0.7.ebuild')
-rw-r--r--dev-python/polygon/polygon-3.0.7.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/polygon/polygon-3.0.7.ebuild b/dev-python/polygon/polygon-3.0.7.ebuild
index e3e7bcdb4135..e9821f63b466 100644
--- a/dev-python/polygon/polygon-3.0.7.ebuild
+++ b/dev-python/polygon/polygon-3.0.7.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python3_6 )
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -30,7 +32,7 @@ python_prepare_all() {
}
python_test() {
- ${PYTHON} test/Test.py || die "Tests failed under ${EPYTHON}"
+ "${EPYTHON}" test/Test.py -v || die "Tests failed under ${EPYTHON}"
}
python_install_all() {