summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-06 07:43:19 +0100
committerSam James <sam@gentoo.org>2022-07-06 07:44:26 +0100
commitc84427352e4d47096430a711ff399c86269d2811 (patch)
tree849c4fae8fe2571a20e1a2c6c73ebcbf9fb5be54 /dev-python/polygon/polygon-3.0.9.ebuild
parentdev-python/mysql-connector-python: treeclean (diff)
downloadgentoo-c84427352e4d47096430a711ff399c86269d2811.tar.gz
gentoo-c84427352e4d47096430a711ff399c86269d2811.tar.bz2
gentoo-c84427352e4d47096430a711ff399c86269d2811.zip
dev-python/polygon: treeclean
Closes: https://bugs.gentoo.org/849824 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/polygon/polygon-3.0.9.ebuild')
-rw-r--r--dev-python/polygon/polygon-3.0.9.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/polygon/polygon-3.0.9.ebuild b/dev-python/polygon/polygon-3.0.9.ebuild
deleted file mode 100644
index 94322a9bfbcf..000000000000
--- a/dev-python/polygon/polygon-3.0.9.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-# this version is untagged in github, and pypi doesn't has tests
-COMMIT=7b2091f77741fa1d94251979bc4a4f2676b4d2d1
-
-DESCRIPTION="Python package to handle polygonal shapes in 2D"
-HOMEPAGE="https://www.j-raedler.de/projects/polygon/
- https://github.com/jraedler/Polygon3"
-SRC_URI="
- https://github.com/jraedler/Polygon3/archive/${COMMIT}.tar.gz
- -> ${P}.gh.tar.gz"
-S="${WORKDIR}/Polygon3-${COMMIT}"
-
-LICENSE="LGPL-2"
-SLOT="3"
-KEYWORDS="amd64 ppc x86"
-IUSE="examples"
-
-DOCS=( doc/{Polygon.txt,Polygon.pdf} )
-
-src_prepare() {
- if use examples; then
- mkdir examples || die
- mv doc/{Examples.py,testpoly.gpf} examples || die
- fi
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- "${EPYTHON}" test/Test.py -v || die "Tests failed under ${EPYTHON}"
-}
-
-src_install() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_src_install
-}