summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-28 09:02:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-28 09:54:05 +0100
commit12943e6da1967efbc206542321fc190542d23d0b (patch)
tree59d0b8ba498fd5a4bd158f634e7658fb0bff9724 /dev-python/pony
parentdev-python/jc: Bump to 1.18.2 (diff)
downloadgentoo-12943e6da1967efbc206542321fc190542d23d0b.tar.gz
gentoo-12943e6da1967efbc206542321fc190542d23d0b.tar.bz2
gentoo-12943e6da1967efbc206542321fc190542d23d0b.zip
dev-python/pony: Bump to 0.7.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pony')
-rw-r--r--dev-python/pony/Manifest1
-rw-r--r--dev-python/pony/pony-0.7.16.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pony/Manifest b/dev-python/pony/Manifest
index c86e6e677a60..932de943bcaa 100644
--- a/dev-python/pony/Manifest
+++ b/dev-python/pony/Manifest
@@ -1,2 +1,3 @@
DIST pony-0.7.14.gh.tar.gz 305795 BLAKE2B a0e056d722a205a00567a230628be6ef8a7fe86f594f91ec0e8bbfc6d6eec17ec1d4cf3f57ad10984b8beb0a90da3010d9a32f2f08dca434af39e20fc6e9126c SHA512 ed27fd697dd14948c282dab6b75e41c9309d0ef4c4cccb0f91e4214e81de52a2de3910e413dfc5495ffcea190a5b50255c45b2beecead84eecb601ba2463d998
DIST pony-0.7.15.gh.tar.gz 268638 BLAKE2B d93dcc21a13834a23c0fcbeec7f6ea98ff6750d1650b00e738d65c7b7985ba7880ddfc8238e4b4f3ee4a302a31b69a4767ea52728e66b5cfe62e0190769e6b8c SHA512 ca81441fe1a714bc863bde33739ae2e65f42d8e763a5c6734517987a4c03faffb08a134517bcc61f5b7941f207e32e4ca02fe12fccca871d481f44a81da12536
+DIST pony-0.7.16.gh.tar.gz 268683 BLAKE2B bee6447116f215cd586e69f29fea37ba3f9953d0a72b28acf612da2d6e1be07e424b704593e42ae1755e898580aaf4f2e61923ff81e6e58fe0cc8ec04a3b8399 SHA512 db9bb06f0e718866eb6f137d5650a2b484119c42f1ade83a7bc1c9e3c27a852ed25e451a226a80bebd050ca3217c0993e59f3b66719a3fe41a98e45349172495
diff --git a/dev-python/pony/pony-0.7.16.ebuild b/dev-python/pony/pony-0.7.16.ebuild
new file mode 100644
index 000000000000..2260573d4ebf
--- /dev/null
+++ b/dev-python/pony/pony-0.7.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python ORM with beautiful query syntax"
+HOMEPAGE="
+ https://ponyorm.org/
+ https://github.com/ponyorm/pony/"
+SRC_URI="
+ https://github.com/ponyorm/pony/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+BDEPEND="test? ( $(python_gen_impl_dep sqlite) )"
+
+distutils_enable_tests unittest