summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-08-15 20:31:18 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-08-15 20:31:41 +0200
commit132bf1db04df2026855a68960f80c60750b2145b (patch)
treea08db49e4d34138acd9e17feac88d8c77f76f288 /dev-python/portalocker
parentdev-ruby/docker-api: new package, add 2.2.0 (diff)
downloadgentoo-132bf1db04df2026855a68960f80c60750b2145b.tar.gz
gentoo-132bf1db04df2026855a68960f80c60750b2145b.tar.bz2
gentoo-132bf1db04df2026855a68960f80c60750b2145b.zip
dev-python/portalocker: add missing dev-python/redis test dep
Closes: https://bugs.gentoo.org/912318 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-python/portalocker')
-rw-r--r--dev-python/portalocker/portalocker-2.7.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/portalocker/portalocker-2.7.0.ebuild b/dev-python/portalocker/portalocker-2.7.0.ebuild
index bf13c3b24040..1129e7ffef3a 100644
--- a/dev-python/portalocker/portalocker-2.7.0.ebuild
+++ b/dev-python/portalocker/portalocker-2.7.0.ebuild
@@ -5,7 +5,8 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_11 )
-inherit distutils-r1
+
+inherit distutils-r1 optfeature
DESCRIPTION="A library for Python file locking"
HOMEPAGE="
@@ -24,6 +25,7 @@ KEYWORDS="~amd64"
BDEPEND="
test? (
+ dev-python/redis[${PYTHON_USEDEP}]
>=dev-python/pytest-timeout-2.1.0[${PYTHON_USEDEP}]
>=dev-python/sphinx-6.0.0[${PYTHON_USEDEP}]
)
@@ -37,3 +39,7 @@ src_prepare() {
# Disable code coverage in tests.
sed -i '/^ *--cov.*$/d' pytest.ini || die
}
+
+pkg_postinst() {
+ optfeature "redis support" dev-python/redis
+}