summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-17 06:42:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-17 06:44:47 +0200
commit267302bd58dcfb67abcbac120cc18b30ce92c15f (patch)
treee2d351eaaab336a57256b84660b0ca026f42f611 /dev-python/portalocker
parentdev-python/setuptools: Remove old (diff)
downloadgentoo-267302bd58dcfb67abcbac120cc18b30ce92c15f.tar.gz
gentoo-267302bd58dcfb67abcbac120cc18b30ce92c15f.tar.bz2
gentoo-267302bd58dcfb67abcbac120cc18b30ce92c15f.zip
dev-python/portalocker: Bump to 2.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/portalocker')
-rw-r--r--dev-python/portalocker/Manifest1
-rw-r--r--dev-python/portalocker/portalocker-2.8.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/portalocker/Manifest b/dev-python/portalocker/Manifest
index 4aee62cab115..b57d3027b596 100644
--- a/dev-python/portalocker/Manifest
+++ b/dev-python/portalocker/Manifest
@@ -1 +1,2 @@
DIST portalocker-2.7.0.gh.tar.gz 29787 BLAKE2B 14c2742978396c0d1bb5bdcd8c3eeb5af676d57bcc5bfb34bbf397655895f66b7c48a3a8d6c035e62aed3278f20ba4e5d5b0d88d0bac01b4dd6bab9e5ebcf40a SHA512 ca1d7c6ec57b4f95d138975f47a3fdaed35be9b580331dbd58159adbbdce63666e82d89eb6bd3ce614778c525fd04144faa4880d5fea976772d72a247999f2c9
+DIST portalocker-2.8.2.gh.tar.gz 32382 BLAKE2B d953165d4e64d4bf5d084a9d5563b6e53515abbddeb7f9a4a49ea3358ff3bafc9631f38322e4a7ff1ab702aff4813eb52b4a7c431f411d767afd0647347d37af SHA512 3772ea6d15ee80d284c7fc7e88bdc9ab7714b460fdca39c2a288e0375c16f430bf9362da06227084dc2e56bd7342bd2d59823a94daf52ca51366e69fe6456236
diff --git a/dev-python/portalocker/portalocker-2.8.2.ebuild b/dev-python/portalocker/portalocker-2.8.2.ebuild
new file mode 100644
index 000000000000..333c026f2774
--- /dev/null
+++ b/dev-python/portalocker/portalocker-2.8.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A library for Python file locking"
+HOMEPAGE="
+ https://github.com/WoLpH/portalocker/
+ https://portalocker.readthedocs.io/
+ https://pypi.org/project/portalocker/
+"
+SRC_URI="
+ https://github.com/WoLpH/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/redis[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-6.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ # Disable code coverage in tests.
+ sed -i '/^ *--cov.*$/d' pytest.ini || die
+}
+
+pkg_postinst() {
+ optfeature "redis support" dev-python/redis
+}