summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-21 16:20:32 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-21 16:20:32 -0800
commit953833b903a1f2b0ba9c69971bacdc2bdd701cdc (patch)
tree3c85e5341cdd97e067b931b945664e866a7c249a /dev-python/portend/portend-2.6.ebuild
parentdev-python/tempora: Revbump to 1.14.1-r1, add py38 (diff)
downloadgentoo-953833b903a1f2b0ba9c69971bacdc2bdd701cdc.tar.gz
gentoo-953833b903a1f2b0ba9c69971bacdc2bdd701cdc.tar.bz2
gentoo-953833b903a1f2b0ba9c69971bacdc2bdd701cdc.zip
dev-python/portend: Version bump to 2.6, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/portend/portend-2.6.ebuild')
-rw-r--r--dev-python/portend/portend-2.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/portend/portend-2.6.ebuild b/dev-python/portend/portend-2.6.ebuild
new file mode 100644
index 000000000000..3c1794c30ef8
--- /dev/null
+++ b/dev-python/portend/portend-2.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="TCP port monitoring utilities"
+HOMEPAGE="https://pypi.org/project/portend/ https://github.com/jaraco/portend"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/tempora-1.8[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # avoid a setuptools_scm dependency
+ sed -i "s:use_scm_version=True:version='${PV}':" setup.py || die
+
+ # avoid extra test deps
+ sed -i -r 's: --flake8:: ; s: --black:: ; s: --cov::' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}