summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-29 16:42:45 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-29 22:43:40 -0500
commit19adfded88fa698aa49dd5310b231e9cb57a3ff5 (patch)
tree1f7c14336a06f1350c52b08df7a9d1c9e3cbf612 /dev-python/positional/positional-1.1.1.ebuild
parentsci-libs/blas-reference: ebuild maintenance, cleanup (diff)
downloadgentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.gz
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.bz2
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.zip
add initial support for newton (keystone)
dropped py3.3 and updated most (maybe all) to eapi6
Diffstat (limited to 'dev-python/positional/positional-1.1.1.ebuild')
-rw-r--r--dev-python/positional/positional-1.1.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/positional/positional-1.1.1.ebuild b/dev-python/positional/positional-1.1.1.ebuild
new file mode 100644
index 000000000000..10d783e49663
--- /dev/null
+++ b/dev-python/positional/positional-1.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A decorator which enforces only some args may be passed positionally."
+HOMEPAGE="https://github.com/morganfainberg/positional"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]"