summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-11 20:02:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-11 21:04:18 +0200
commit9a137456ffb1cefe013d88078498312381f96770 (patch)
treefdf6cf01b89846a015b9b935f064a938e140cacc /dev-python/pplpy
parentdev-python/hcloud: Remove old (diff)
downloadgentoo-9a137456ffb1cefe013d88078498312381f96770.tar.gz
gentoo-9a137456ffb1cefe013d88078498312381f96770.tar.bz2
gentoo-9a137456ffb1cefe013d88078498312381f96770.zip
dev-python/pplpy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pplpy')
-rw-r--r--dev-python/pplpy/Manifest1
-rw-r--r--dev-python/pplpy/pplpy-0.8.9.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/pplpy/Manifest b/dev-python/pplpy/Manifest
index 7753555568cc..f8d6a7f443cd 100644
--- a/dev-python/pplpy/Manifest
+++ b/dev-python/pplpy/Manifest
@@ -1,2 +1 @@
DIST pplpy-0.8.10.tar.gz 64203 BLAKE2B b0735722a051ef33b7415528147a84a163ac49bf5d07e2f6599a7bbf004140abf5e6a09b7f0555ac57b55614a1c059bba20cc7ac7fe47a83f429e33d7f0dd1bc SHA512 982d36291cd0108786e47cb1ff73127ba2b2a619edc697e28360a87ace743e7fc6dd04e32aab38d41724d455de4861065f9ac3d409fd2f68114b07f4d1328c23
-DIST pplpy-0.8.9.tar.gz 66017 BLAKE2B 90da3b4c3e992d0ca969925d8142b114fbbfd5214a768f2e56825d8689e2c4aa2e68a3fa45da9df68168a28413153eb189df277157823e88503668be5c26505c SHA512 618a0a1d603e2859313ad4f71b3cc40156a06371c6b8971fdab8275f6676fc19510e3927828c641819399b5ea6646e954738309fbf8c10fba5733c7410ed75fc
diff --git a/dev-python/pplpy/pplpy-0.8.9.ebuild b/dev-python/pplpy/pplpy-0.8.9.ebuild
deleted file mode 100644
index 8b4cc0104598..000000000000
--- a/dev-python/pplpy/pplpy-0.8.9.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_EXT=1
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python bindings for the Parma Polyhedra Library (PPL)"
-HOMEPAGE="https://pypi.org/project/pplpy/
- https://github.com/sagemath/pplpy"
-
-# The file headers under ppl/ contain the "or later" bit
-LICENSE="GPL-3+"
-
-# API/ABI changes in point releases
-SLOT="0/${PV}"
-KEYWORDS="amd64"
-IUSE="doc"
-
-DEPEND="dev-libs/ppl
- dev-python/cysignals[${PYTHON_USEDEP}]
- dev-python/gmpy[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_compile() {
- # Parallel build breaks the test suite somehow. This should be
- # reported upstream but first someone will need to figure out
- # how to reproduce it outside of Gentoo.
- distutils-r1_python_compile -j 1
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all(){
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
-
-python_test(){
- "${EPYTHON}" setup.py test || die
-}