summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-25 06:14:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-25 06:14:29 +0100
commitaa8be175e7dc9a41b41b1799972f43eeaf177a89 (patch)
tree5e18179e95a9792941705b222daf75a37cf67528 /dev-python/pplpy
parentdev-python/pplpy: Bump to 0.8.10 (diff)
downloadgentoo-aa8be175e7dc9a41b41b1799972f43eeaf177a89.tar.gz
gentoo-aa8be175e7dc9a41b41b1799972f43eeaf177a89.tar.bz2
gentoo-aa8be175e7dc9a41b41b1799972f43eeaf177a89.zip
dev-python/pplpy: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pplpy')
-rw-r--r--dev-python/pplpy/pplpy-0.8.10.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-python/pplpy/pplpy-0.8.10.ebuild b/dev-python/pplpy/pplpy-0.8.10.ebuild
index cd6c0247648a..66bea27018d0 100644
--- a/dev-python/pplpy/pplpy-0.8.10.ebuild
+++ b/dev-python/pplpy/pplpy-0.8.10.ebuild
@@ -3,9 +3,9 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_USE_PEP517=setuptools
DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -32,15 +32,18 @@ RDEPEND="
"
BDEPEND="
dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
distutils_enable_sphinx docs/source
-python_compile() {
- # Parallel build breaks the test suite somehow. This should be
- # reported upstream but first someone will need to figure out
- # how to reproduce it outside of Gentoo.
- distutils-r1_python_compile -j 1
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all(){
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
}
python_test(){