summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2018-08-01 00:00:34 +0100
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2018-08-01 22:01:48 +0100
commiteb3ddb110e1f5d297adaa68caf0313d4837b7f6c (patch)
treec0ecd34683a9fd65b5304572099e430ad425ace0 /dev-python/precis-i18n/precis-i18n-1.0.0.ebuild
parentapp-portage/gverify: New package for gentoo.git verification tool (diff)
downloadgentoo-eb3ddb110e1f5d297adaa68caf0313d4837b7f6c.tar.gz
gentoo-eb3ddb110e1f5d297adaa68caf0313d4837b7f6c.tar.bz2
gentoo-eb3ddb110e1f5d297adaa68caf0313d4837b7f6c.zip
dev-python/precis-i18n: Add package, needed for net-im/gajim bump
Thanks to Alex <maniac@pzskc383.dp.ua> for initial version of the ebuild. Gentoo-Bug: 651616
Diffstat (limited to 'dev-python/precis-i18n/precis-i18n-1.0.0.ebuild')
-rw-r--r--dev-python/precis-i18n/precis-i18n-1.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/precis-i18n/precis-i18n-1.0.0.ebuild b/dev-python/precis-i18n/precis-i18n-1.0.0.ebuild
new file mode 100644
index 000000000000..64ef7198e16e
--- /dev/null
+++ b/dev-python/precis-i18n/precis-i18n-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Internationalized Usernames and Passwords"
+HOMEPAGE="https://pypi.python.org/pypi/precis-i18n"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ esetup.py test
+}