summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-12 07:45:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-12 07:50:36 +0200
commit5080dfaa235788112229ea6bf43bdc6afbf680b8 (patch)
tree688f6d9df4928f38e8c83cdf195404950db3440e /dev-python/prettytable/prettytable-3.9.0.ebuild
parentdev-python/google-auth-oauthlib: Bump to 1.1.0 (diff)
downloadgentoo-5080dfaa235788112229ea6bf43bdc6afbf680b8.tar.gz
gentoo-5080dfaa235788112229ea6bf43bdc6afbf680b8.tar.bz2
gentoo-5080dfaa235788112229ea6bf43bdc6afbf680b8.zip
dev-python/prettytable: Bump to 3.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prettytable/prettytable-3.9.0.ebuild')
-rw-r--r--dev-python/prettytable/prettytable-3.9.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/prettytable/prettytable-3.9.0.ebuild b/dev-python/prettytable/prettytable-3.9.0.ebuild
new file mode 100644
index 000000000000..e7e226037a5e
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.9.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest