summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-07 00:17:41 +0100
committerMichał Górny <mgorny@gentoo.org>2021-05-07 13:10:56 +0200
commit073255a0bfa9e6503f554e4bbdec6c8c30b6653e (patch)
tree12faaff4a34cce76e381b29c8b800faa148d772e /dev-python/priority/priority-1.3.0.ebuild
parentdev-python/bottle: Port to python3.10 (diff)
downloadgentoo-073255a0bfa9e6503f554e4bbdec6c8c30b6653e.tar.gz
gentoo-073255a0bfa9e6503f554e4bbdec6c8c30b6653e.tar.bz2
gentoo-073255a0bfa9e6503f554e4bbdec6c8c30b6653e.zip
dev-python/priority: Port to python3.10
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/priority/priority-1.3.0.ebuild')
-rw-r--r--dev-python/priority/priority-1.3.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/priority/priority-1.3.0.ebuild b/dev-python/priority/priority-1.3.0.ebuild
index 3e4f4d560589..a7435505739c 100644
--- a/dev-python/priority/priority-1.3.0.ebuild
+++ b/dev-python/priority/priority-1.3.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_{7,8,9})
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -16,7 +17,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-DEPEND="
+BDEPEND="
test? ( >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}] )
"