summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/processing
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/processing')
-rw-r--r--dev-python/processing/Manifest1
-rw-r--r--dev-python/processing/metadata.xml8
-rw-r--r--dev-python/processing/processing-0.52-r1.ebuild33
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/processing/Manifest b/dev-python/processing/Manifest
new file mode 100644
index 000000000000..c6128798ebd9
--- /dev/null
+++ b/dev-python/processing/Manifest
@@ -0,0 +1 @@
+DIST processing-0.52.zip 178013 SHA256 976fa4f8d30e8dc8216ae24d44c95587ae05ab39e9ac4bdc10691cab51fca11d SHA512 ce5244eefe1bed629afddf2309ea61f44a2a5fe913b97032752ecd92e58add278f7bcf02c5dc9e1985720ceaaa2e4d547f67e9b018313a26ca084c2a86f0efb3 WHIRLPOOL f0e243253d1ea8d7d67c3f209ad5cafa6d0f9f571a77566db7aa25294f3b252b5b3120450c7b149231edc0c6ffd1901725d0373617553de7c554f6a686f54b88
diff --git a/dev-python/processing/metadata.xml b/dev-python/processing/metadata.xml
new file mode 100644
index 000000000000..7e66f50bca02
--- /dev/null
+++ b/dev-python/processing/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">processing</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/processing/processing-0.52-r1.ebuild b/dev-python/processing/processing-0.52-r1.ebuild
new file mode 100644
index 000000000000..76176717d52f
--- /dev/null
+++ b/dev-python/processing/processing-0.52-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 flag-o-matic
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Package for using processes, which mimics the threading module API"
+HOMEPAGE="http://pyprocessing.berlios.de/ http://pypi.python.org/pypi/processing"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${PYTHON_DEPS}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ append-flags -fno-strict-aliasing
+}