summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-11-21 10:37:04 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-11-21 10:37:04 +0100
commit2cf22213851d9aaab5b541a6ec0785174b5d336a (patch)
tree1ccf93a8020e55260577678fd3c585c321a049ec /dev-python/prometheus_client
parentapp-admin/helm: Version bump to 3.0.0 (diff)
downloadgentoo-2cf22213851d9aaab5b541a6ec0785174b5d336a.tar.gz
gentoo-2cf22213851d9aaab5b541a6ec0785174b5d336a.tar.bz2
gentoo-2cf22213851d9aaab5b541a6ec0785174b5d336a.zip
dev-python/prometheus_client: Version bump to 0.7.1
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'dev-python/prometheus_client')
-rw-r--r--dev-python/prometheus_client/Manifest1
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.7.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/Manifest b/dev-python/prometheus_client/Manifest
index e20bdb304092..fdb6da44c8bb 100644
--- a/dev-python/prometheus_client/Manifest
+++ b/dev-python/prometheus_client/Manifest
@@ -1,2 +1,3 @@
DIST prometheus_client-0.5.0.tar.gz 60184 BLAKE2B cc44537b051c053860520d412664d57aaa6d35dd491409de0da72b9859743cc355d67eb260c2381347ad3313df9efa498535ff130df317b103d8c815f34f28eb SHA512 6e6e6c0f859b7b9d593e1059b71fde8eed15ccd95e54c245b4e0e8edb748a4761f0929f2d6c06f1c4656eb81f26959c5cec6a58f4d725a587b433ffbb4582127
DIST prometheus_client-0.6.0.tar.gz 60790 BLAKE2B fa8eaddfedb9598394fec0c6464499ed5bcace9969e843126422414e397d31985a44a626be0257a235f6d5f685fd8d6bb55fc0d92928f0b9729ab9f097f1958b SHA512 a2b92683f939961c567c266a54699de6f37088cd4e61c9d9a5f4451228b4c3bfa4c517e4a5187867f5463d726a8dc6e7fdae30973c1e9aa9aa1a03247b2e99cd
+DIST prometheus_client-0.7.1.tar.gz 62880 BLAKE2B 8878a6e6a20f96443f1f14ffbb74eda7dc6f1f48151901da047ade6342ddd7858b4dcd808d80af64a3eff449c1c7425f9eb9f3d1283b65e8e6067c6b5fe2f9c4 SHA512 84b145ed191c9903d390b152c72de4f2afcb4c500b8debba59ded081f00cc76109b336ed2d7783d59e9922ea2927632f7ef730f336974294b20048c51e9d58a4
diff --git a/dev-python/prometheus_client/prometheus_client-0.7.1.ebuild b/dev-python/prometheus_client/prometheus_client-0.7.1.ebuild
new file mode 100644
index 000000000000..de2f35ea9f69
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.7.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.org/project/prometheus_client/"
+SRC_URI="https://github.com/prometheus/client_python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+S=${WORKDIR}/client_python-${PV}
+
+RDEPEND="|| ( dev-python/twisted[${PYTHON_USEDEP}] dev-python/twisted-web[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -v || die
+}