summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-09 18:20:15 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-09 18:20:45 +0200
commit562fe1bde1383b94ef8bb4bc9f81269c002983f1 (patch)
treef30a7c76f618f690f6d2583be8aeefa5b7cea4a4 /dev-python/prometheus_client
parentdev-python/prometheus_client: Port to py3.9 (diff)
downloadgentoo-562fe1bde1383b94ef8bb4bc9f81269c002983f1.tar.gz
gentoo-562fe1bde1383b94ef8bb4bc9f81269c002983f1.tar.bz2
gentoo-562fe1bde1383b94ef8bb4bc9f81269c002983f1.zip
dev-python/prometheus_client: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prometheus_client')
-rw-r--r--dev-python/prometheus_client/Manifest1
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.8.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/Manifest b/dev-python/prometheus_client/Manifest
index a627f643d9ab..358b4b06a610 100644
--- a/dev-python/prometheus_client/Manifest
+++ b/dev-python/prometheus_client/Manifest
@@ -1 +1,2 @@
DIST prometheus_client-0.7.1.tar.gz 62880 BLAKE2B 8878a6e6a20f96443f1f14ffbb74eda7dc6f1f48151901da047ade6342ddd7858b4dcd808d80af64a3eff449c1c7425f9eb9f3d1283b65e8e6067c6b5fe2f9c4 SHA512 84b145ed191c9903d390b152c72de4f2afcb4c500b8debba59ded081f00cc76109b336ed2d7783d59e9922ea2927632f7ef730f336974294b20048c51e9d58a4
+DIST prometheus_client-0.8.0.tar.gz 67749 BLAKE2B 570c95de0d4e9e8bd625d55eb3dd450cf933ab7c8b6af74ff56414045f4d845c4a74f60d60e8b29f868801de12ebe2d39b5ac11701071c4998aec66719581b3f SHA512 a9d49bc4dac77168f94edf51344042bc5210b07ed01031dc50e323f86ea8292df7370956a4fbd9d9f85a0857a8ec9abaef30c0c2cd4dc5502df7264816eecc8f
diff --git a/dev-python/prometheus_client/prometheus_client-0.8.0.ebuild b/dev-python/prometheus_client/prometheus_client-0.8.0.ebuild
new file mode 100644
index 000000000000..b795fd68f556
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.8.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.org/project/prometheus_client/
+ https://github.com/prometheus/client_python"
+SRC_URI="https://github.com/prometheus/client_python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/client_python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/twisted[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest