summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-02-05 17:30:47 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-02-05 17:30:47 +0100
commitb35288f7963c0fd830699eebbd71cba683bd2928 (patch)
treeaad01653e59dacb7bcd95eb229f9e6631227190e /dev-python/prometheus_client
parentsys-devel/gdb: Version bump to 8.1 (diff)
downloadgentoo-b35288f7963c0fd830699eebbd71cba683bd2928.tar.gz
gentoo-b35288f7963c0fd830699eebbd71cba683bd2928.tar.bz2
gentoo-b35288f7963c0fd830699eebbd71cba683bd2928.zip
dev-python/prometheus_client: Version bump to 0.1.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/prometheus_client')
-rw-r--r--dev-python/prometheus_client/Manifest1
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.1.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/Manifest b/dev-python/prometheus_client/Manifest
index a07643b58eba..f85b662129cc 100644
--- a/dev-python/prometheus_client/Manifest
+++ b/dev-python/prometheus_client/Manifest
@@ -1 +1,2 @@
DIST prometheus_client-0.0.21.tar.gz 40859 BLAKE2B 58e7a49e12e4f9c865624de24e51e30d4cee75f2f3afd446aa53d425a9aa9ac20829c043ab29036e4e24ef90e06f5950616745ee8f8d89de20e8b1b01d63579f SHA512 e948ecc9044bd6a59fdc58bb3dd638c89d210a5856a360b4270eff206b2280ef7a68c1e94aea64f5cfb68a218499e61627e34c71363ff222b1a3d27403396a31
+DIST prometheus_client-0.1.1.tar.gz 41513 BLAKE2B 3816b34a809c8e40da6fab221bf020bd3d4169c6d1e96a4c48631133cff4fc2839bf1ee01df67711ed4d8c4a38b6ad53c612cddbbb9a7fe45a9b3887cce900e2 SHA512 ac343f416dc4f9907e4da0de19d2005375102fb552491025d76466dee1fb1be753a8e20380c83276116a1606a32a9373db53e8a2952669d511255438d74ba217
diff --git a/dev-python/prometheus_client/prometheus_client-0.1.1.ebuild b/dev-python/prometheus_client/prometheus_client-0.1.1.ebuild
new file mode 100644
index 000000000000..3f109c2efec7
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.python.org/pypi/prometheus_client"
+SRC_URI="https://github.com/prometheus/client_python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+S=${WORKDIR}/client_python-${PV}
+
+RDEPEND="|| ( dev-python/twisted[${PYTHON_USEDEP}] dev-python/twisted-web[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest || die
+}