summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-04-03 14:20:00 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-04-03 14:20:00 +0200
commitdca92e169738076761044381c489b1d17c10b30a (patch)
tree4c1ece198dada1ecd1afeafff45db59994207011 /dev-python/prometheus_client
parentdev-perl/TheSchwartz: amd64 stable (diff)
downloadgentoo-dca92e169738076761044381c489b1d17c10b30a.tar.gz
gentoo-dca92e169738076761044381c489b1d17c10b30a.tar.bz2
gentoo-dca92e169738076761044381c489b1d17c10b30a.zip
dev-python/prometheus_client: Version bump to 0.2.0
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-python/prometheus_client')
-rw-r--r--dev-python/prometheus_client/Manifest1
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/Manifest b/dev-python/prometheus_client/Manifest
index f85b662129cc..33d188f27f1c 100644
--- a/dev-python/prometheus_client/Manifest
+++ b/dev-python/prometheus_client/Manifest
@@ -1,2 +1,3 @@
DIST prometheus_client-0.0.21.tar.gz 40859 BLAKE2B 58e7a49e12e4f9c865624de24e51e30d4cee75f2f3afd446aa53d425a9aa9ac20829c043ab29036e4e24ef90e06f5950616745ee8f8d89de20e8b1b01d63579f SHA512 e948ecc9044bd6a59fdc58bb3dd638c89d210a5856a360b4270eff206b2280ef7a68c1e94aea64f5cfb68a218499e61627e34c71363ff222b1a3d27403396a31
DIST prometheus_client-0.1.1.tar.gz 41513 BLAKE2B 3816b34a809c8e40da6fab221bf020bd3d4169c6d1e96a4c48631133cff4fc2839bf1ee01df67711ed4d8c4a38b6ad53c612cddbbb9a7fe45a9b3887cce900e2 SHA512 ac343f416dc4f9907e4da0de19d2005375102fb552491025d76466dee1fb1be753a8e20380c83276116a1606a32a9373db53e8a2952669d511255438d74ba217
+DIST prometheus_client-0.2.0.tar.gz 41574 BLAKE2B c8e0288f37d1d3e6548283105dd6ba1e4cae5a6f1846c776538de1a68a2eebe6387f8212631c07f2c37839204262d0f555f1a5edb624c0d7418753123c296ca4 SHA512 7336d8294ef91dfebe91f325a882105cdaf947de212bff651d1c3ebfc139d9045b7f637ea44b18e921a9f2ad9af554aee28587e57b1202b5a30c49b1a765ba4c
diff --git a/dev-python/prometheus_client/prometheus_client-0.2.0.ebuild b/dev-python/prometheus_client/prometheus_client-0.2.0.ebuild
new file mode 100644
index 000000000000..3f109c2efec7
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.python.org/pypi/prometheus_client"
+SRC_URI="https://github.com/prometheus/client_python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+S=${WORKDIR}/client_python-${PV}
+
+RDEPEND="|| ( dev-python/twisted[${PYTHON_USEDEP}] dev-python/twisted-web[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest || die
+}