summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-02 17:59:45 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-02 18:30:34 +0200
commit1a531badd7942e2e914da17bef1de7da50a11df1 (patch)
tree1c7a412c19256c9b84c442715838b12932654364 /dev-python/prompt_toolkit/prompt_toolkit-0.48.ebuild
parentdev-python/django-extensions: Version Bump (diff)
downloadgentoo-1a531badd7942e2e914da17bef1de7da50a11df1.tar.gz
gentoo-1a531badd7942e2e914da17bef1de7da50a11df1.tar.bz2
gentoo-1a531badd7942e2e914da17bef1de7da50a11df1.zip
dev-python/prompt_toolkit: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/prompt_toolkit/prompt_toolkit-0.48.ebuild')
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-0.48.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-0.48.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-0.48.ebuild
new file mode 100644
index 000000000000..d3cd17779255
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-0.48.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="https://pypi.python.org/pypi/prompt_toolkit/ https://github.com/jonathanslenders/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# not contained in tarball
+RESTRICT="test"
+
+python_test() {
+ "${PYTHON}" "${S}"/tests/run_tests.py || die
+}