summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-05-17 17:39:35 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-05-18 09:42:01 +0000
commita0667b411d05bcfa17a23c9b0ba8ad1807111fd3 (patch)
tree7ef6198e1a3fb653ecf136914b64d3777b05306b /dev-python/prompt_toolkit/prompt_toolkit-1.0.0.ebuild
parentx11-misc/xdialog: Housekeeping + missing die. (diff)
downloadgentoo-a0667b411d05bcfa17a23c9b0ba8ad1807111fd3.tar.gz
gentoo-a0667b411d05bcfa17a23c9b0ba8ad1807111fd3.tar.bz2
gentoo-a0667b411d05bcfa17a23c9b0ba8ad1807111fd3.zip
dev-python/prompt_toolkit: Version bump to 1.0.0
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1480 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/prompt_toolkit/prompt_toolkit-1.0.0.ebuild')
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-1.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-1.0.0.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-1.0.0.ebuild
new file mode 100644
index 000000000000..0b512caa00de
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="https://pypi.python.org/pypi/prompt_toolkit/ https://github.com/jonathanslenders/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${PYTHON}" "${S}"/tests/run_tests.py || die
+}