summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Linder <linder.gabriel@gmail.com>2019-12-08 13:37:21 +0100
committerAaron Bauman <bman@gentoo.org>2019-12-12 14:31:32 -0500
commita6d6ad821c22ace82fd728e30bd9916195ba62ff (patch)
treed50537c690a36b48024fd1c88d85195a8908c09f /dev-python/prompt_toolkit/prompt_toolkit-2.0.10.ebuild
parentdev-python/pysvg: drop old Py2 only version (diff)
downloadgentoo-a6d6ad821c22ace82fd728e30bd9916195ba62ff.tar.gz
gentoo-a6d6ad821c22ace82fd728e30bd9916195ba62ff.tar.bz2
gentoo-a6d6ad821c22ace82fd728e30bd9916195ba62ff.zip
dev-python/prompt_toolkit: bump to version 2.0.10.
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Gabriel Linder <linder.gabriel@gmail.com> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/prompt_toolkit/prompt_toolkit-2.0.10.ebuild')
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-2.0.10.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-2.0.10.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-2.0.10.ebuild
new file mode 100644
index 000000000000..d119b248c58a
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-2.0.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="https://pypi.org/project/prompt_toolkit/ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest