summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-11-14 20:11:36 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-11-14 20:11:36 +0700
commitb347b9bd331e27377b90ab0aa46be3e8f4174cfc (patch)
treea8e8afaf516058701b832f46eba6b014eaee4269 /dev-python/prompt_toolkit/prompt_toolkit-2.0.7.ebuild
parentapp-admin/ansible: 2.6.7 and 2.5.11 stable amd64 and x86 (diff)
downloadgentoo-b347b9bd331e27377b90ab0aa46be3e8f4174cfc.tar.gz
gentoo-b347b9bd331e27377b90ab0aa46be3e8f4174cfc.tar.bz2
gentoo-b347b9bd331e27377b90ab0aa46be3e8f4174cfc.zip
dev-python/prompt_toolkit: bump to 2.0.7
Signed-off-by: Andrey Grozin <grozin@gentoo.org> Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-python/prompt_toolkit/prompt_toolkit-2.0.7.ebuild')
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-2.0.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-2.0.7.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-2.0.7.ebuild
new file mode 100644
index 000000000000..23d9ed1bf792
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-2.0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="https://pypi.org/project/prompt_toolkit/ https://github.com/jonathanslenders/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die
+}