summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-09 08:38:22 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-09 09:07:44 +0100
commit9de9ab6e5cb0cf0ede9c4968bc9319817a09616b (patch)
tree624ba00b850059d98bfbfa11f0cce4a808ff42d1 /dev-python/prompt_toolkit/prompt_toolkit-3.0.10.ebuild
parentdev-python/cfn-python-lint: Bump to 0.44.3 (diff)
downloadgentoo-9de9ab6e5cb0cf0ede9c4968bc9319817a09616b.tar.gz
gentoo-9de9ab6e5cb0cf0ede9c4968bc9319817a09616b.tar.bz2
gentoo-9de9ab6e5cb0cf0ede9c4968bc9319817a09616b.zip
dev-python/prompt_toolkit: Bump to 3.0.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prompt_toolkit/prompt_toolkit-3.0.10.ebuild')
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.10.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.10.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.10.ebuild
new file mode 100644
index 000000000000..48d2f9a60858
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest