summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-07 20:33:24 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-07 21:30:02 +0100
commit24a7bac40653e42123d5082b72660f4044d6607b (patch)
treeae4e0e5b6a991f5abf06f37d89a2a2a0aa0233f7 /dev-python/prompt_toolkit
parentdev-python/bitarray: Bump to 2.3.6 (diff)
downloadgentoo-24a7bac40653e42123d5082b72660f4044d6607b.tar.gz
gentoo-24a7bac40653e42123d5082b72660f4044d6607b.tar.bz2
gentoo-24a7bac40653e42123d5082b72660f4044d6607b.zip
dev-python/prompt_toolkit: Bump to 3.0.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prompt_toolkit')
-rw-r--r--dev-python/prompt_toolkit/Manifest1
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.27.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index 5bbfb1fc9b5a..07dcba12b040 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -1,2 +1,3 @@
DIST prompt_toolkit-3.0.24.tar.gz 3042044 BLAKE2B e9b4186a38756cf6c0d92575e42dfe4507e63f721038374252e7a7d5af76f7df04dc01251079d99a74167aef7e394b50c43b5190df8b9cd68cf74eae31dfbe51 SHA512 e423735441407ffe51d46225efa4b747899d47fa5d5a2163e5c0c906d2f1937e80a67bcd06ff6aa97d8a336e507fd0322957e79b9382d1a678994060fcccfb84
DIST prompt_toolkit-3.0.26.tar.gz 402667 BLAKE2B 60160c3e0059b570321d182699b2e6cc10e7d771e9c328314e5561329aec5ddb4951d5cd50d49414314d50a9542e223b44e9c589d272ccf32bfb4f54ed1a9980 SHA512 7151d6678409bf3b04bee76cbcf4e0ffb5ca1963c359d30c8edf9e81bde424ea69b7009cd44e6d72088936290e2fd9dd8cac59efc8b5e59bfb87dacf53967b05
+DIST prompt_toolkit-3.0.27.tar.gz 3056711 BLAKE2B 920c9d56f634644dde4b25c95e794b3652e4fb4afb652982ff767f798812e63b48138f0f2fd82e081e8c47fe27c69c525622b7caf56ca95565d11955e72abc5a SHA512 5249c245e183101d92d7a26030cb69b425d6aa719dd4d134cc2e7102f7c4e593c3d18c753108bfa855ca72cbe1c68ade28f65b1029dae55db5168296c6dfd5b2
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.27.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.27.ebuild
new file mode 100644
index 000000000000..bef28012e7a3
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.27.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest