summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-18 05:44:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-18 06:41:35 +0200
commitd55d03dd53ddc4f9a098fb16ee892eac8196993e (patch)
tree71347490b7fd90c28ae4eca27623e8fea53e68d0 /dev-python/prompt_toolkit
parentdev-python/GitPython: Bump to 3.1.18 (diff)
downloadgentoo-d55d03dd53ddc4f9a098fb16ee892eac8196993e.tar.gz
gentoo-d55d03dd53ddc4f9a098fb16ee892eac8196993e.tar.bz2
gentoo-d55d03dd53ddc4f9a098fb16ee892eac8196993e.zip
dev-python/prompt_toolkit: Bump to 3.0.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prompt_toolkit')
-rw-r--r--dev-python/prompt_toolkit/Manifest1
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.19.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index 12fb580f308b..b2ae4327ffa1 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -1 +1,2 @@
DIST prompt_toolkit-3.0.18.tar.gz 3034754 BLAKE2B 27334b7009fc162af67a1fa14bd30c76efed6a333c5c93f3100a2c9ad3299a1139c3c3cf530e7e048b5700c0dc4ec1087d1aecd5412785b09221ea2d55796008 SHA512 be2dbd72a1e08553c0e50453958b6085a7d743464acd02b303e5002e1174d672d2cadd7a992e71d0445aa2f2be7565411ae4d00c3677c275eca056a20ad9efc8
+DIST prompt_toolkit-3.0.19.tar.gz 3034818 BLAKE2B d1f0741931d4711952cfaabd992e64aa3fd252627c50f2a0ad8ad1aef5882bd4ae054c0d281b141595488fda6328c102f900445a42bc32cf018d37663deb2cb5 SHA512 0f3f7c5a2d12e03e06e900a4239f86f27d959fa7337d072dae8c79bbcd2ffd4c1026d1531210e34a4f4669d483b20b9d2f49c7625d0d7aa1fcb1e3f9f3894349
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.19.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.19.ebuild
new file mode 100644
index 000000000000..8bdd09a6bfe1
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.19.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest