summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-15 09:06:34 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-15 13:32:39 +0200
commit510e00b4c577190f198aeb5461dade7f67b13068 (patch)
treeac28f2ea282aa43a422221951bc12cfbd8c6c0b7 /dev-python/proto-plus
parentdev-python/proto-plus: Remove old (diff)
downloadgentoo-510e00b4c577190f198aeb5461dade7f67b13068.tar.gz
gentoo-510e00b4c577190f198aeb5461dade7f67b13068.tar.bz2
gentoo-510e00b4c577190f198aeb5461dade7f67b13068.zip
dev-python/proto-plus: Bump to 1.20.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/Manifest1
-rw-r--r--dev-python/proto-plus/proto-plus-1.20.6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index 413476a3304e..52c81221ee81 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1,3 +1,4 @@
DIST proto-plus-1.20.3.gh.tar.gz 66941 BLAKE2B 359d95d37b8a4dad282cb9b33909982ffedca25cd3907583d689996d6e516143c0e4eb2b9bb06bc50e12fabe197f0622a3488cf21136decefe676980b20c7a9e SHA512 411089eb76508a5ca94d6b4228dd4bc1f8d01d4f5209bb2ab0e6e240d8061761c9c76cd03b3a4da7771b45a30df3b0ca4c17f7fca3ed6e710a9724ab7bc0f60d
DIST proto-plus-1.20.4.gh.tar.gz 67455 BLAKE2B 6121d8bd87127139b6b6c16055941cb320fb2a106ae5a95f77a949ffffaa99db474282255a88994d3194866c404633d953d8a136e55ddbd2163d8da08bbde8cc SHA512 f71aa0e956f63bb8dab205e2788185efd31bcd733299fedd4f24d407b3c1b3bfedc24e349769644025c6dbc8775e7743ee96be4dac2edc8b6406101a5da604df
DIST proto-plus-1.20.5.gh.tar.gz 67573 BLAKE2B d764c8afb4608c38b050c256930a7ea37ee8d5393518e3146a66d11d4fee1cf3b35142426442d014483bd1ac5b815b6445b0f2c2c04f404136aeb6031a944e54 SHA512 bf612f23af3cf30cceaf8ee2027a721cc37dbe7e17d0ce643c31361397409171f92e92a6b53163e747931c3b0da66edca638ae4014c096bc0e3a8f1bc5dc8e80
+DIST proto-plus-1.20.6.gh.tar.gz 67697 BLAKE2B 88fbf1086bc9430360316c89baaf6216d3f395792fbc2bf1336c22aeb4f912dedd5a4af73c5a10cf6536cdc4cf285c89d1d0a86afd4ee21c7e40b26d34631240 SHA512 5da41a8ddabb34a4083b622d60e59532cd7cb97e4fd243b796aded06ee0f6d9ba5ac847434aa8141b90cb3481d45fbc703de2f905ff4f4676a5d86d77a01c44c
diff --git a/dev-python/proto-plus/proto-plus-1.20.6.ebuild b/dev-python/proto-plus/proto-plus-1.20.6.ebuild
new file mode 100644
index 000000000000..6be65f5713cd
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.20.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="
+ https://github.com/googleapis/proto-plus-python/
+ https://pypi.org/project/proto-plus/
+"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/google-api-core-1.31.5[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme