summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-20 09:45:34 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-20 10:29:25 +0200
commit66ddbc9e712013e17b5a1fe2f6d521933420643e (patch)
tree0293259f1735a4b4079f52c138f4e27ff9f38e48 /dev-python/proto-plus
parentdev-python/python-utils: Bump to 3.2.3 (diff)
downloadgentoo-66ddbc9e712013e17b5a1fe2f6d521933420643e.tar.gz
gentoo-66ddbc9e712013e17b5a1fe2f6d521933420643e.tar.bz2
gentoo-66ddbc9e712013e17b5a1fe2f6d521933420643e.zip
dev-python/proto-plus: Bump to 1.20.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/Manifest1
-rw-r--r--dev-python/proto-plus/proto-plus-1.20.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index 8dd4862c6649..4f8550429cca 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1,3 +1,4 @@
DIST proto-plus-1.20.0.gh.tar.gz 65648 BLAKE2B 19cfcfde913896de83d17c36bacd7799a9f28ea20c4681266b2194c6521aef116f6a594df8be8912bdf55558d84a0ab09d283ec444ba114592ebb7017db257fe SHA512 1e399bc0ac686f33242c1d15c15255ec1815e94eaf87de03e5145cc6ed249048c3b8af081b70964cb7b6baf8286f6be2f461c3638331a2269a5b2d89976ffa6a
DIST proto-plus-1.20.1.gh.tar.gz 66180 BLAKE2B ee0299c8e9c9882ce417f6f885df18cd833dfbad80e0e92ca4e589eea794b0b00577d4c01fa69790f97f31d8bdfd20f07f4c7601bdf6ee28a7427f0e56714eb4 SHA512 12d9f76230d592c68083421bbb40c4b57741545c238227a743c275820a4d7ae53ea45d7ae5e73495b14736a95aa96250e243220f8b9bb5c988c12a2f84f654d6
DIST proto-plus-1.20.3.gh.tar.gz 66941 BLAKE2B 359d95d37b8a4dad282cb9b33909982ffedca25cd3907583d689996d6e516143c0e4eb2b9bb06bc50e12fabe197f0622a3488cf21136decefe676980b20c7a9e SHA512 411089eb76508a5ca94d6b4228dd4bc1f8d01d4f5209bb2ab0e6e240d8061761c9c76cd03b3a4da7771b45a30df3b0ca4c17f7fca3ed6e710a9724ab7bc0f60d
+DIST proto-plus-1.20.4.gh.tar.gz 67455 BLAKE2B 6121d8bd87127139b6b6c16055941cb320fb2a106ae5a95f77a949ffffaa99db474282255a88994d3194866c404633d953d8a136e55ddbd2163d8da08bbde8cc SHA512 f71aa0e956f63bb8dab205e2788185efd31bcd733299fedd4f24d407b3c1b3bfedc24e349769644025c6dbc8775e7743ee96be4dac2edc8b6406101a5da604df
diff --git a/dev-python/proto-plus/proto-plus-1.20.4.ebuild b/dev-python/proto-plus/proto-plus-1.20.4.ebuild
new file mode 100644
index 000000000000..9946d728f496
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.20.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="
+ https://github.com/googleapis/proto-plus-python/
+ https://pypi.org/project/proto-plus/
+"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme