summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2021-04-06 02:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2021-04-09 18:32:19 -0400
commit34e62908d9cfa774cb872371715bae1dd1498918 (patch)
tree086bf357c70851ecc739422ffc559b127d143d68 /dev-python/protobuf-python/protobuf-python-3.15.2.ebuild
parentdev-java/protobuf-java: Version bumps (3.15.*). (diff)
downloadgentoo-34e62908d9cfa774cb872371715bae1dd1498918.tar.gz
gentoo-34e62908d9cfa774cb872371715bae1dd1498918.tar.bz2
gentoo-34e62908d9cfa774cb872371715bae1dd1498918.zip
dev-python/protobuf-python: Version bumps (3.15.*).
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python/protobuf-python/protobuf-python-3.15.2.ebuild')
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.15.2.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/protobuf-python/protobuf-python-3.15.2.ebuild b/dev-python/protobuf-python/protobuf-python-3.15.2.ebuild
new file mode 100644
index 000000000000..c3065bbdad23
--- /dev/null
+++ b/dev-python/protobuf-python/protobuf-python-3.15.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2008-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf"
+ EGIT_SUBMODULES=()
+fi
+
+DESCRIPTION="Google's Protocol Buffers - Python bindings"
+HOMEPAGE="https://developers.google.com/protocol-buffers/ https://github.com/protocolbuffers/protobuf"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> protobuf-${PV}.tar.gz"
+fi
+
+LICENSE="BSD"
+SLOT="0/26"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ ~dev-libs/protobuf-${PV}
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${PYTHON_DEPS}
+ ~dev-libs/protobuf-${PV}"
+RDEPEND="${BDEPEND}
+ !<dev-libs/protobuf-3[python(-)]"
+
+S="${WORKDIR}/protobuf-${PV}/python"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_CHECKOUT_DIR="${WORKDIR}/protobuf-${PV}"
+fi
+
+python_prepare_all() {
+ pushd "${WORKDIR}/protobuf-${PV}" > /dev/null || die
+ eapply "${FILESDIR}/${PN}-3.13.0-google.protobuf.pyext._message.PyUnknownFieldRef.patch"
+ eapply_user
+ popd > /dev/null || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ mydistutilsargs=(--cpp_implementation)
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${ED}" -name "*.pth" -type f -delete || die
+}