summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 07:36:44 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-02 07:44:29 +0100
commit0733decf83801cdb55c17d071b283b7183cd5b20 (patch)
tree0731eea5f137260b263ecfec2b1073a8a079c6b6 /dev-python/psycopg
parentdev-python/pybind11: Remove old (diff)
downloadgentoo-0733decf83801cdb55c17d071b283b7183cd5b20.tar.gz
gentoo-0733decf83801cdb55c17d071b283b7183cd5b20.tar.bz2
gentoo-0733decf83801cdb55c17d071b283b7183cd5b20.zip
dev-python/psycopg: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/Manifest1
-rw-r--r--dev-python/psycopg/psycopg-2.9.2.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index 0b468d4b76a3..9fd0d28dc886 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -1,3 +1,2 @@
DIST psycopg2-2.8.6.tar.gz 383797 BLAKE2B da0e3f1e143c51c940ba1f51d3e457b492d880ab71267dacd4747444bc767711ccd6c2f54d9e10ce5ad8fae0c3206fb4b6199f267e9bbaf12eb654227f59c2b0 SHA512 1e1d5d8755c6d1a153d84210bf29902afafe853659d709e13abc6bc5772def13779d2394690af1c544384c9c607edc0fe5cf2763244fb346febf9a9e0032b45f
-DIST psycopg2-2.9.2.tar.gz 380253 BLAKE2B f3b649986f8bec56df33858373e510ea69623fc38416f6344c7b63e4c82b412d24edd1b0cadcbf391e8920626ac86e81388e916711ab4d5c6dfc3f88070f5d8f SHA512 96b15db1a8c597dc7b6a725aa67952bcbac8e0e3d4f1cea97c7ffa14b272d21b4c16fd567edbbb4a01aa2c4b01c0bba562cdeea1f678aebf2139aa171dacd0a8
DIST psycopg2-2.9.3.tar.gz 380611 BLAKE2B 78099da7378dcfa8b7f28aae4d533a7e890cdb7ae4c0cc718a9411e630fd07b56f074760fc29de8fe08fe727328cca39414a5f297fb92ed2f7471a24e633d18d SHA512 048184d1d162a371fc0fba711448a6fa8a6aac193421f4484c7f7b91c39065d5b632fa34fc15a901eca055d597302b1f9e38330b248ed0e4653dcdc544b0d660
diff --git a/dev-python/psycopg/psycopg-2.9.2.ebuild b/dev-python/psycopg/psycopg-2.9.2.ebuild
deleted file mode 100644
index 1ecb5a72507c..000000000000
--- a/dev-python/psycopg/psycopg-2.9.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-MY_PN="${PN}2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="PostgreSQL database adapter for Python"
-HOMEPAGE="https://www.psycopg.org https://pypi.org/project/psycopg2/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="LGPL-3+"
-SLOT="2"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="debug test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-db/postgresql-8.1:*"
-DEPEND="${RDEPEND}"
-BDEPEND="
- test? ( >=dev-db/postgresql-8.1[server] )"
-
-python_prepare_all() {
- if use debug; then
- sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- initdb -D "${T}"/pgsql || die
- # TODO: random port
- pg_ctl -w -D "${T}"/pgsql start \
- -o "-h '' -k '${T}'" || die
- createdb -h "${T}" psycopg2_test || die
-
- local -x PSYCOPG2_TESTDB_HOST="${T}"
- distutils-r1_src_test
-
- pg_ctl -w -D "${T}"/pgsql stop || die
-}
-
-python_test() {
- "${EPYTHON}" -c "
-import tests
-tests.unittest.main(defaultTest='tests.test_suite')
-" --verbose || die "Tests fail with ${EPYTHON}"
-}