summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-24 08:43:45 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-24 13:09:22 +0200
commit97c8dc23190cfc2231ba54d893b4ac79a7b5a067 (patch)
tree36465546bb90f8ebc0e691c7d5b839351bc3f42b /dev-python/ptpython
parentdev-python/ldap3: Version Bump (diff)
downloadgentoo-97c8dc23190cfc2231ba54d893b4ac79a7b5a067.tar.gz
gentoo-97c8dc23190cfc2231ba54d893b4ac79a7b5a067.tar.bz2
gentoo-97c8dc23190cfc2231ba54d893b4ac79a7b5a067.zip
dev-python/ptpython: Version Bump
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/ptpython')
-rw-r--r--dev-python/ptpython/Manifest1
-rw-r--r--dev-python/ptpython/ptpython-0.24.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ptpython/Manifest b/dev-python/ptpython/Manifest
index f4008519e046..9bcdda160ae3 100644
--- a/dev-python/ptpython/Manifest
+++ b/dev-python/ptpython/Manifest
@@ -1,3 +1,4 @@
DIST ptpython-0.20.tar.gz 29618 SHA256 a6ebe6f6e496693c69f460e46296492832b47997a0feea069b386cf9bee5bc4f SHA512 2ff701d65f449676bd51cad6287723497a6ff8dd2dda5daf992125892c9d1131bfce7c648e8d53260e9d9a33d648ed1b97bb32f60253c106e6f96a58dcece848 WHIRLPOOL c5ab855f747f785c5c29f54346eac6285779dfea054073caea4769e6a92593e48fc84fc2ed69cfcc6f44b17e1323f646c8a6070c892bcf1caf66f128ea748ff6
DIST ptpython-0.21.tar.gz 27410 SHA256 37aad517cf9d55e567697fe001bc2d07e7013753218537f78425c2bac1181a0b SHA512 d85c7167932cfc033324bf62e96b27ee9296eab92fc1f3ce9e4afac5af6f4e5bfaee1950fcdc76121acd7176efe79c61d6cb2b06a59e7a9a5c5c34a1b41a64d1 WHIRLPOOL 5290c0389893c13c8f4a69a4726faea984be62748ce0beff400e7b7eb8ef5fe1a352f0e37a2afc991d869d69c9afeaaee3c76a00c1157037bd35227d1837285f
DIST ptpython-0.22.tar.gz 40261 SHA256 b5f23bbf59e134f222c3eef0c60163fe0c212628d23f3756b7923ebb57603536 SHA512 76fbd2ce2db41f4918a2583cd1a5b2518b747fd09483e541a80df617f003cd9fc3d1c9d9699f50479b00f43ba651af49fb5cf44ddc0ba863d92949de0f182594 WHIRLPOOL 770f6544c10bad1632e7b58ec9af97baf611a1b15f40df1ab76a4a81ec080730716cf129f86c54767b0da3b4dfc1fb510f3479fd9953f3831bf77e8b78de7748
+DIST ptpython-0.24.tar.gz 41967 SHA256 6dfb728183e92447de5b4de4ac1f6caa07c2ae29e10402166c9ec9921e3bf661 SHA512 38d0f34e8b9747bbab2d24d50fa06093b0b0e0431357ad00204af5f4d0707930b36d7ee22cb72accb34557832510cc9996fd525e64cb5959819a2ccc8fabbdeb WHIRLPOOL fee4beed23ab8e362281e1a88674abb22e31aeb341b5144c5bc10dbfaccd1b186f69dc42b6153d9d5c88dda9b937e6594f9e74c6a2e8a90f1bd587b69e53b37f
diff --git a/dev-python/ptpython/ptpython-0.24.ebuild b/dev-python/ptpython/ptpython-0.24.ebuild
new file mode 100644
index 000000000000..8da28ad9c65a
--- /dev/null
+++ b/dev-python/ptpython/ptpython-0.24.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python REPL build on top of prompt_toolkit"
+HOMEPAGE="https://pypi.python.org/pypi/ptpython/ https://github.com/jonathanslenders/ptpython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/prompt_toolkit-0.52[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.9.0[${PYTHON_USEDEP}]
+ dev-python/docopt[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+pkg_postinst() {
+ optfeature "ipython enhanced version" dev-python/ipython
+}